summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2023-10-23 13:15:10 +0200
committerCarl Smedstad2023-10-23 13:46:50 +0200
commitdaa78ea01a2988e05632114f182338e9c13b0c11 (patch)
tree7b2c5749cbc6f4b7885aa321a7c2742c0ecc11bb
parent83b5030a5e58c0a9bff829e7441dd364892f1724 (diff)
downloadaur-daa78ea01a2988e05632114f182338e9c13b0c11.tar.gz
Publish version 2.53.17.1-2 - Force building with Rust 1.72.0
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f277dae5bb52..dde931da5b64 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = seamonkey
pkgdesc = SeaMonkey internet suite
pkgver = 2.53.17.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.seamonkey-project.org
install = seamonkey.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 1d391987de87..52722a999b33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=seamonkey
pkgver=2.53.17.1
-pkgrel=1
+pkgrel=2
pkgdesc="SeaMonkey internet suite"
arch=(x86_64)
url="https://www.seamonkey-project.org"
@@ -89,26 +89,30 @@ _mozilla_api_key=e05d56db0a694edc8b5aaebda3f2db6a
_archive="$pkgname-$pkgver"
+_rust_toolchain_version=1.72.0
+
prepare() {
cd "$_archive"
cp "$srcdir/mozconfig" .mozconfig
- rustup toolchain install 1.72.0
+ rustup toolchain install "$_rust_toolchain_version"
echo -n "$_google_api_key" > google-api-key
echo -n "$_mozilla_api_key" > mozilla-api-key
- cat >> .mozconfig << EOF
- ac_add_options --with-google-location-service-api-keyfile=${PWD@Q}/google-api-key
- ac_add_options --with-google-safebrowsing-api-keyfile=${PWD@Q}/google-api-key
- ac_add_options --with-mozilla-api-keyfile=${PWD@Q}/mozilla-api-key
-EOF
+ {
+ echo "ac_add_options --with-google-location-service-api-keyfile=${PWD@Q}/google-api-key"
+ echo "ac_add_options --with-google-safebrowsing-api-keyfile=${PWD@Q}/google-api-key"
+ echo "ac_add_options --with-mozilla-api-keyfile=${PWD@Q}/mozilla-api-key"
+ } >> .mozconfig
}
build() {
cd "$_archive"
+ export RUSTUP_TOOLCHAIN="$_rust_toolchain_version"
+
# Don't use mold - fails.
LDFLAGS=$(printf '%s' "$LDFLAGS" | sed 's/-fuse-ld=[^[:space:]]*//')
export LDFLAGS