summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracgtyrant2016-02-23 11:25:29 +0800
committeracgtyrant2016-02-23 11:25:29 +0800
commit82d6678bd5d8259bad32cc8a3b5d92bd804b2c22 (patch)
tree01742d001824a383147c9e51cf9688135730dd3e
parent8004441e80b551337ba40fe7619573346d76870c (diff)
downloadaur-82d6678bd5d8259bad32cc8a3b5d92bd804b2c22.tar.gz
This now depends on zenity instead of python-easygui.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b815eba35513..7e846766a05d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Dec 24 03:40:41 UTC 2015
+# Tue Feb 23 03:25:20 UTC 2016
pkgbase = search-and-view-git
pkgdesc = Tools to make searching and viewing easy.
pkgver = r12.df55f03
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/lilydjwg/search-and-view
arch = any
license = GPL3
@@ -11,7 +11,7 @@ pkgbase = search-and-view-git
depends = bash
depends = the_silver_searcher
depends = python
- depends = python-easygui
+ depends = zenity
optdepends = python-setproctitle: agv support
optdepends = vim: vv support
source = git+https://github.com/lilydjwg/search-and-view.git
diff --git a/PKGBUILD b/PKGBUILD
index 08bd7dad7449..1de9b46bdbc2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,27 @@
# Maintainer: acgtyrant <acgtyrant@gmail.com>
+
_pkgname=search-and-view
-pkgname=${_pkgname}-git
+pkgname=$_pkgname-git
pkgver=r12.df55f03
-pkgrel=2
+pkgrel=3
pkgdesc="Tools to make searching and viewing easy."
arch=('any')
url="https://github.com/lilydjwg/search-and-view"
license=('GPL3')
-depends=('bash' 'the_silver_searcher' 'python' 'python-easygui')
+depends=('bash' 'the_silver_searcher' 'python' 'zenity')
makedepends=('git')
optdepends=('python-setproctitle: agv support' 'vim: vv support')
source=('git+https://github.com/lilydjwg/search-and-view.git')
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/${_pkgname}"
+ cd "$srcdir/$_pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
cd "$srcdir/${_pkgname}"
- install -Dm 755 agg "${pkgdir}/usr/bin/agg"
- install -Dm 755 agv "${pkgdir}/usr/bin/agv"
- install -Dm 755 vv "${pkgdir}/usr/bin/vv"
+ install -Dm 755 agg "$pkgdir/usr/bin/agg"
+ install -Dm 755 agv "$pkgdir/usr/bin/agv"
+ install -Dm 755 vv "$pkgdir/usr/bin/vv"
}