summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Walladge2019-08-19 14:34:39 +0930
committerSamuel Walladge2019-08-19 14:34:39 +0930
commitd2ba76788b64e53c6fed45ce47a2fdca8cac23eb (patch)
tree691f5227b6c990b8cb9dbd6e854824ce54941a08
downloadaur-d2ba76788b64e53c6fed45ce47a2fdca8cac23eb.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f90cc919e99a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = searchr-git
+ pkgdesc = Command line local plain text files indexer and searcher
+ pkgver = v0.1.0.r0.g9205590
+ pkgrel = 1
+ url = https://github.com/swalladge/pc
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ license = MIT
+ makedepends = cargo
+ makedepends = git
+ provides = searchr
+ conflicts = searchr
+ source = searchr-git::git+https://github.com/swalladge/searchr
+ sha256sums = SKIP
+
+pkgname = searchr-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12564670aa24
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Samuel Walladge <samuel@swalladge.net>
+pkgname=searchr-git
+_pkgname=searchr
+pkgver=v0.1.0.r0.g9205590
+pkgrel=1
+pkgdesc="Command line local plain text files indexer and searcher"
+arch=('i686' 'x86_64')
+url="https://github.com/swalladge/pc"
+license=('APACHE' 'MIT')
+provides=("searchr")
+conflicts=("searchr")
+makedepends=('cargo' 'git')
+source=("$pkgname::git+https://github.com/swalladge/searchr")
+sha256sums=('SKIP')
+
+build() {
+ cd "$pkgname"
+ cargo build --release
+}
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 "target/release/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+
+ install -Dm644 "README.md" "$pkgdir/usr/share/doc/${_pkgname}/README.md"
+ install -Dm644 "LICENSE-APACHE" "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE-APACHE"
+ install -Dm644 "LICENSE-MIT" "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE-MIT"
+}
+