summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuang Luong2018-12-17 18:25:50 +0800
committerQuang Luong2018-12-17 18:25:50 +0800
commit587c81607a98c2a83bb180076fb97478a422bfc7 (patch)
tree06ec35e96e5809538c5e46e4b6371e9e7699fb57
downloadaur-587c81607a98c2a83bb180076fb97478a422bfc7.tar.gz
init
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD34
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c2da5cba48a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = seastar-git
+ pkgdesc = High performance server-side application framework
+ pkgver = r4026.e67572ef
+ pkgrel = 1
+ url = https://github.com/scylladb/seastar
+ arch = x86_64
+ license = Apache-2
+ makedepends = git
+ makedepends = cmake
+ makedepends = gcc
+ makedepends = ragel
+ depends = hwloc
+ depends = boost
+ depends = boost-libs
+ depends = hwloc
+ depends = numactl
+ depends = libpciaccess
+ depends = crypto++
+ depends = libxml2
+ depends = xfsprogs
+ depends = gnutls
+ depends = lksctp-tools
+ depends = lz4
+ depends = systemtap
+ depends = libtool
+ depends = yaml-cpp
+ source = git+https://github.com/scylladb/seastar#branch=master
+ sha256sums = SKIP
+
+pkgname = seastar-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..387e87c1de9d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+pkgname=seastar-git
+pkgdesc='High performance server-side application framework'
+pkgver=r4026.e67572ef
+pkgrel=1
+arch=('x86_64')
+url='https://github.com/scylladb/seastar'
+license=('Apache-2')
+depends=('hwloc' 'boost' 'boost-libs' 'hwloc' 'numactl' 'libpciaccess' 'crypto++' 'libxml2' 'xfsprogs' 'gnutls' 'lksctp-tools' 'lz4' 'systemtap' 'libtool' 'yaml-cpp')
+makedepends=('git' 'cmake' 'gcc' 'ragel')
+source=("git+https://github.com/scylladb/seastar#branch=master")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/seastar"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+prepare() {
+ cd seastar
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .. -DSeastar_DEMOES=OFF -DSeastar_DOCS=OFF -DSeastar_TESTING=OFF -DSeastar_APPS=OFF
+}
+
+build() {
+ cd seastar/build
+ make
+}
+
+package() {
+ cd seastar/build
+ make DESTDIR="$pkgdir" install
+ cd "$pkgdir" && mv usr/lib64 usr/lib
+}