summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2020-03-07 18:12:09 +0000
committerJonathon Fernyhough2020-03-07 18:12:09 +0000
commita4431f366f3bcd618b4b4b90e483aa51156a4be3 (patch)
tree4da3f0db55f04dc8ad2da0558a83104b7ec953b0
downloadaur-a4431f366f3bcd618b4b4b90e483aa51156a4be3.tar.gz
Initial commit. Upstream 1.58.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b9ba968e72c2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = seaweedfs
+ pkgdesc = SeaweedFS is a simple and highly scalable distributed file system
+ pkgver = 1.58
+ pkgrel = 1
+ url = https://github.com/chrislusf/seaweedfs
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ arch = armv6h
+ arch = arm
+ license = APACHE
+ makedepends = go-pie
+ source = seaweedfs-1.58.tar.gz::https://github.com/chrislusf/seaweedfs/archive/1.58.tar.gz
+ sha256sums = fbb2d7da12a89ad3a467cff51262c808e8aab88607b88906748aad2ed456326c
+
+pkgname = seaweedfs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68574526a19c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=seaweedfs
+pkgver=1.58
+pkgrel=1
+pkgdesc="SeaweedFS is a simple and highly scalable distributed file system"
+arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h' 'arm')
+url="https://github.com/chrislusf/seaweedfs"
+license=('APACHE')
+makedepends=('go-pie')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('fbb2d7da12a89ad3a467cff51262c808e8aab88607b88906748aad2ed456326c')
+
+build() {
+ cd $pkgname-$pkgver
+ make GOPATH="$srcdir"
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -D weed/weed "$pkgdir"/usr/bin/weed
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/$pkgname/README.md
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}