summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2021-11-18 02:07:15 +0000
committerJonathon Fernyhough2021-11-18 02:07:15 +0000
commitd8b2853f0f59cef362885987ee6aecbc0952b389 (patch)
tree71ab4ba17adac08494f880aba7d7cec303659385
parente6f17a950f770cfff6dec3f3c29c917f47f86b8a (diff)
downloadaur-d8b2853f0f59cef362885987ee6aecbc0952b389.tar.gz
Upstream 2.78. Enable large disk support.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2cf03d23ed3d..2a5a04f0b94b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = seaweedfs
pkgdesc = SeaweedFS is a simple and highly scalable distributed file system
- pkgver = 2.76
+ pkgver = 2.78
pkgrel = 1
url = https://github.com/chrislusf/seaweedfs
arch = i686
@@ -12,7 +12,7 @@ pkgbase = seaweedfs
license = APACHE
makedepends = git
makedepends = go
- source = seaweedfs-2.76.tar.gz::https://github.com/chrislusf/seaweedfs/archive/2.76.tar.gz
- sha256sums = ca73c4eac55463db95dfbcecb32ab89e93eb1402ac5cf66f1e1c31a0cf9d70b6
+ source = seaweedfs-2.78.tar.gz::https://github.com/chrislusf/seaweedfs/archive/2.78.tar.gz
+ sha256sums = 3babe46101b9b465b2885efdda079beb788d8534b7adb0cef26c2e8970552110
pkgname = seaweedfs
diff --git a/PKGBUILD b/PKGBUILD
index f435c3fa1729..957c99e67a41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: krevedko <helllamer-gmail.com>
pkgname=seaweedfs
-pkgver=2.76
+pkgver=2.78
pkgrel=1
pkgdesc="SeaweedFS is a simple and highly scalable distributed file system"
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h' 'arm')
@@ -10,7 +10,7 @@ url="https://github.com/chrislusf/seaweedfs"
license=('APACHE')
makedepends=('git' 'go')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('ca73c4eac55463db95dfbcecb32ab89e93eb1402ac5cf66f1e1c31a0cf9d70b6')
+sha256sums=('3babe46101b9b465b2885efdda079beb788d8534b7adb0cef26c2e8970552110')
_shortcommit=84d2e1b
prepare() {
@@ -29,7 +29,7 @@ build() {
export GOPATH="${SRCDEST:-$srcdir}"
cd $pkgname-$pkgver/weed
- go build -v $GO_FLAGS -ldflags "-X github.com/chrislusf/seaweedfs/weed/util.COMMIT=$_shortcommit -extldflags $LDFLAGS"
+ go build -v $GO_FLAGS -tags 5BytesOffset -ldflags "-X github.com/chrislusf/seaweedfs/weed/util.COMMIT=$_shortcommit -extldflags $LDFLAGS"
}
#check() {