summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2020-06-21 15:27:48 +0100
committerJonathon Fernyhough2020-06-21 15:27:48 +0100
commitdfadc5be2a7dc330321fc6d8924b87376a0bb094 (patch)
tree5abfa316d479b402702df809e857666ee2b1a36e
parent0d9d109b4bb986d6bb28a70e01e7ab02d5d9d4ea (diff)
downloadaur-dfadc5be2a7dc330321fc6d8924b87376a0bb094.tar.gz
Upstream 1.82. Patch LDFLAGS.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
-rw-r--r--ldflags.patch13
3 files changed, 32 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 986936341d76..a83c234fcde5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = seaweedfs
pkgdesc = SeaweedFS is a simple and highly scalable distributed file system
- pkgver = 1.79
+ pkgver = 1.82
pkgrel = 1
url = https://github.com/chrislusf/seaweedfs
arch = i686
@@ -11,8 +11,10 @@ pkgbase = seaweedfs
arch = arm
license = APACHE
makedepends = go
- source = seaweedfs-1.79.tar.gz::https://github.com/chrislusf/seaweedfs/archive/1.79.tar.gz
- sha256sums = cab9296b27d12727e5e5cca2c537aeb0da8981775b999a7e2e55f7efd0bf97e7
+ source = seaweedfs-1.82.tar.gz::https://github.com/chrislusf/seaweedfs/archive/1.82.tar.gz
+ source = ldflags.patch
+ sha256sums = 9660f9296b57dd790f3970b8f2fb03c0bbdc54c563081105104ab713441acf2c
+ sha256sums = 64db3c34767099aab8ec385c0b6796a2745ed66fa35159df0e8108da31e710db
pkgname = seaweedfs
diff --git a/PKGBUILD b/PKGBUILD
index 77e184da410c..aab5b4ea6178 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,32 @@
pkgname=seaweedfs
-pkgver=1.79
+pkgver=1.82
pkgrel=1
pkgdesc="SeaweedFS is a simple and highly scalable distributed file system"
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h' 'arm')
url="https://github.com/chrislusf/seaweedfs"
license=('APACHE')
makedepends=('go')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('cab9296b27d12727e5e5cca2c537aeb0da8981775b999a7e2e55f7efd0bf97e7')
-
-export CGO_LDFLAGS="$LDFLAGS"
-export GOFLAGS="-buildmode=pie -trimpath -mod=vendor -modcacherw"
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
+ ldflags.patch)
+sha256sums=('9660f9296b57dd790f3970b8f2fb03c0bbdc54c563081105104ab713441acf2c'
+ '64db3c34767099aab8ec385c0b6796a2745ed66fa35159df0e8108da31e710db')
prepare() {
cd $pkgname-$pkgver
+
+ patch -Np1 -i ../ldflags.patch
+
export GOPATH="${SRCDEST:-$srcdir}"
go mod vendor
}
build() {
+ export CGO_CPPFLAGS="$CPPFLAGS"
+ export CGO_CFLAGS="$CFLAGS"
+ export CGO_CXXFLAGS="$CXXFLAGS"
+ export CGO_LDFLAGS="$LDFLAGS"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=vendor -modcacherw"
+
cd $pkgname-$pkgver
make GOPATH="${SRCDEST:-$srcdir}"
}
diff --git a/ldflags.patch b/ldflags.patch
new file mode 100644
index 000000000000..894e5bff6beb
--- /dev/null
+++ b/ldflags.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 59a3c46..1d285ed 100644
+--- a/Makefile
++++ b/Makefile
+@@ -34,7 +34,7 @@ deps:
+ rm -rf /home/travis/gopath/src/go.etcd.io/etcd/vendor/golang.org/x/net/trace
+
+ build: deps
+- go build $(GO_FLAGS) -ldflags "$(LDFLAGS)" -o $(BINARY) $(SOURCE_DIR)
++ go build $(GO_FLAGS) -ldflags "-X github.com/chrislusf/seaweedfs/weed/util.COMMIT=${COMMIT} -extldflags $(LDFLAGS)" -o $(BINARY) $(SOURCE_DIR)
+
+ linux: deps
+ mkdir -p linux