summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2016-02-27 13:06:08 +0100
committerNicolas Iooss2016-02-27 13:06:08 +0100
commitc2dd96dccade0dc611cfe8c59824be7331bbc586 (patch)
treeb9278c1e3c7bcdca4018fc05f3b9b06a6d60adb3
downloadaur-c2dd96dccade0dc611cfe8c59824be7331bbc586.tar.gz
Create package for secilc
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..864db3770b11
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by makepkg 5.0.0
+# Sat Feb 27 11:50:48 UTC 2016
+pkgbase = secilc
+ pkgdesc = SELinux Common Intermediate Language Compiler
+ pkgver = 2.5
+ pkgrel = 1
+ url = https://github.com/SELinuxProject/cil/wiki
+ arch = i686
+ arch = x86_64
+ groups = selinux
+ license = GPL
+ makedepends = xmlto
+ makedepends = docbook-xml
+ makedepends = docbook-xsl
+ depends = libsepol>=2.5
+ source = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20160223/secilc-2.5.tar.gz
+ sha256sums = 4303d911c06ee5c207e00f778ca786c1a6efa2554a562f5d014dbc0d2f4cc4a4
+
+pkgname = secilc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f79e5702dd72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
+
+pkgname=secilc
+pkgver=2.5
+pkgrel=1
+pkgdesc="SELinux Common Intermediate Language Compiler"
+groups=('selinux')
+arch=('i686' 'x86_64')
+url='https://github.com/SELinuxProject/cil/wiki'
+license=('GPL')
+makedepends=('xmlto' 'docbook-xml' 'docbook-xsl')
+depends=('libsepol>=2.5')
+source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20160223/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('4303d911c06ee5c207e00f778ca786c1a6efa2554a562f5d014dbc0d2f4cc4a4')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ make all
+}
+
+check() {
+ cd "${pkgname}-${pkgver}"
+ make test
+}
+
+package(){
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}