summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy2020-11-24 12:24:24 -0800
committerAndy2020-11-24 12:24:24 -0800
commitb7906bdf23cce033bef8259758542ae8f69e54a2 (patch)
treeb47e014d01e8b1fb3e5f7527797d313060fc250d
downloadaur-b7906bdf23cce033bef8259758542ae8f69e54a2.tar.gz
Version 1.2.0-1
Initial Release on AUR
-rw-r--r--.SRCINFO44
-rw-r--r--.gitignore5
-rw-r--r--ChangeLog15
-rw-r--r--PKGBUILD35
4 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f2985d8d25d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,44 @@
+pkgbase = secondfaqtor
+ pkgdesc = Two-Factor Authenticator
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://realityripple.com/Software/Applications/SecondFactor/For-Linux/
+ changelog = ChangeLog
+ arch = any
+ license = Unlicense
+ makedepends = gambas3-devel
+ depends = gambas3-gb-image>=3.15
+ depends = gambas3-gb-image<=3.99.0
+ depends = gambas3-gb-qt5>=3.15
+ depends = gambas3-gb-qt5<=3.99.0
+ depends = gambas3-gb-form>=3.15
+ depends = gambas3-gb-form<=3.99.0
+ depends = gambas3-gb-data>=3.15
+ depends = gambas3-gb-data<=3.99.0
+ depends = gambas3-gb-dbus>=3.15
+ depends = gambas3-gb-dbus<=3.99.0
+ depends = gambas3-gb-desktop>=3.15
+ depends = gambas3-gb-desktop<=3.99.0
+ depends = gambas3-gb-form-stock>=3.15
+ depends = gambas3-gb-form-stock<=3.99.0
+ depends = gambas3-gb-openssl>=3.15
+ depends = gambas3-gb-openssl<=3.99.0
+ depends = gambas3-gb-sdl2-audio>=3.15
+ depends = gambas3-gb-sdl2-audio<=3.99.0
+ depends = gambas3-gb-util-web>=3.15
+ depends = gambas3-gb-util-web<=3.99.0
+ depends = gambas3-gb-desktop-x11>=3.15
+ depends = gambas3-gb-desktop-x11<3.99.0
+ depends = zbar
+ source = https://realityripple.com/Software/Applications/SecondFactor/For-Linux/AUR/SecondFaqtor-1.2.0.tar.bz2
+ source = https://realityripple.com/Software/Applications/SecondFactor/For-Linux/AUR/SecondFaqtor-1.2.0.tar.bz2.sig
+ source = https://realityripple.com/Software/Applications/SecondFactor/For-Linux/AUR/secondfaqtor.desktop
+ source = https://realityripple.com/Software/Applications/SecondFactor/For-Linux/AUR/secondfaqtor.desktop.sig
+ validpgpkeys = 2BE391EF8EF9DB1E9BF546620B7C73813443493A
+ sha256sums = 5d0ba5dcd0cdac7664d4c69c8e8069766fe1112442ba2b2b28830b1e0aa1b2f0
+ sha256sums = 8e79cfc46cf400e02a7b4fe98bff25ecb959c512ed7f1e1f5a32f0175fdeaf4e
+ sha256sums = 70e6ce665d759ed7e6057ad3b5fbbd34413fdc50cbf7b813b4a80a83e8f3610d
+ sha256sums = 63d453bf8db7cfcbf1ec029a6ec57df9d35b66d35c908f206db6cf4f82514ac0
+
+pkgname = secondfaqtor
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..681ad61bb337
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+*.sig
+*.desktop
+*.pkg.tar.bz2
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..24a9013df7fe
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,15 @@
+* Sun Nov 22 2020 Andrew Sachen <webmaster@RealityRipple.com> 1.2.0
+- Removed QT4 support
+
+* Wed Oct 28 2020 Andrew Sachen <webmaster@RealityRipple.com> 1.1.0
+- Simplified DBus methodology (for Fedora's sake)
+
+* Sat Oct 24 2020 Andrew Sachen <webmaster@RealityRipple.com> 1.1.0
+- Aligned internal Pbkdf2 call with implementation
+- Fixed Past and Future box width scaling
+- Added a warning if Zbar is missing
+- Require Gambas 3.15 (native OpenSSL functions)
+- Update GridView and ListBox Code
+
+* Wed Mar 11 2020 Andrew Sachen <webmaster@RealityRipple.com> 1.0.0
+- Initial release
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af5bcce9e253
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer : Andrew Sachen <webmaster@RealityRipple.com>
+
+pkgname=secondfaqtor
+_realname=SecondFaqtor
+pkgdesc="Two-Factor Authenticator"
+pkgver=1.2.0
+pkgrel=1
+arch=('any')
+url="https://realityripple.com/Software/Applications/SecondFactor/For-Linux/"
+changelog=ChangeLog
+license=('Unlicense')
+depends=('gambas3-gb-image>=3.15' 'gambas3-gb-image<=3.99.0' 'gambas3-gb-qt5>=3.15' 'gambas3-gb-qt5<=3.99.0' 'gambas3-gb-form>=3.15' 'gambas3-gb-form<=3.99.0' 'gambas3-gb-data>=3.15' 'gambas3-gb-data<=3.99.0' 'gambas3-gb-dbus>=3.15' 'gambas3-gb-dbus<=3.99.0' 'gambas3-gb-desktop>=3.15' 'gambas3-gb-desktop<=3.99.0' 'gambas3-gb-form-stock>=3.15' 'gambas3-gb-form-stock<=3.99.0' 'gambas3-gb-openssl>=3.15' 'gambas3-gb-openssl<=3.99.0' 'gambas3-gb-sdl2-audio>=3.15' 'gambas3-gb-sdl2-audio<=3.99.0' 'gambas3-gb-util-web>=3.15' 'gambas3-gb-util-web<=3.99.0' 'gambas3-gb-desktop-x11>=3.15' 'gambas3-gb-desktop-x11<3.99.0' 'zbar')
+makedepends=('gambas3-devel')
+source=("https://realityripple.com/Software/Applications/SecondFactor/For-Linux/AUR/SecondFaqtor-$pkgver.tar.bz2"{,.sig} "https://realityripple.com/Software/Applications/SecondFactor/For-Linux/AUR/secondfaqtor.desktop"{,.sig})
+sha256sums=('5d0ba5dcd0cdac7664d4c69c8e8069766fe1112442ba2b2b28830b1e0aa1b2f0' '8e79cfc46cf400e02a7b4fe98bff25ecb959c512ed7f1e1f5a32f0175fdeaf4e' '70e6ce665d759ed7e6057ad3b5fbbd34413fdc50cbf7b813b4a80a83e8f3610d' '63d453bf8db7cfcbf1ec029a6ec57df9d35b66d35c908f206db6cf4f82514ac0')
+
+validpgpkeys=('2BE391EF8EF9DB1E9BF546620B7C73813443493A') # Andrew Sachen
+
+build() {
+ cd ${srcdir}/SecondFaqtor
+
+ gbc3 -e -a -g -t -x && gba3
+}
+
+package() {
+ cd ${srcdir}/SecondFaqtor
+
+ install -d ${pkgdir}/usr/bin
+ install -m755 SecondFaqtor.gambas ${pkgdir}/usr/bin/SecondFaqtor
+ ln -s 'SecondFaqtor' "${pkgdir}"/usr/bin/'secondfaqtor'
+ install -D icon.png \
+ ${pkgdir}/usr/share/pixmaps/SecondFaqtor.png
+ install -D ../secondfaqtor.desktop \
+ ${pkgdir}/usr/share/applications/secondfaqtor.desktop
+}