summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrLi2022-05-24 19:20:19 +0800
committerBrLi2022-05-24 19:20:19 +0800
commit93974a97ce9bc99bf6daece28deac32f9a9d67f5 (patch)
treee453f200860cc708bdc15a32e025d039bcb90ca0
parent483f481f7e15fb80af89d5d105cef180bac3780a (diff)
downloadaur-93974a97ce9bc99bf6daece28deac32f9a9d67f5.tar.gz
fix file name and add sed lines
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
-rw-r--r--secureboot-helper-kernel.hook (renamed from secureboot-helper.hook)0
3 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e72a2fe3338..29c0532b7334 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = secureboot-helper
pkgdesc = Kernel signing helper for UEFI secure boot
- pkgver = 1.1.0
+ pkgver = 1.1.1
pkgrel = 1
url = https://wiki.archlinux.org/index.php/Secure_Boot#Signing_kernel_with_pacman_hook
arch = any
@@ -25,16 +25,15 @@ pkgbase = secureboot-helper
backup = etc/secureboot/keys/PK/PK.key
backup = etc/secureboot/keys/PK/rm_PK.auth
backup = etc/secureboot/keys/GUID.txt
- source = secureboot-helper.hook
+ source = secureboot-helper-kernel.hook
source = secureboot-helper-systemd.hook
source = secureboot-helper-ucode.hook
source = systemd-boot-update.hook
source = secureboot-helper.sysusers
sha256sums = 0e52f034ba8576b1723e07f974ea8a7d689cc41488cee731a6e0cb510a2cd4be
sha256sums = fa56188cb7d1175283ad7bbdc06a540ba8c1a2fc1b5ea55011a3a2cca0f7ac4c
- sha256sums = 00cf821b99f5851aed9b1eff2cc242d651017ab3d164605541c66d817fbebadb
+ sha256sums = badc4c0a167af7606df2076929d3ccede9da971b9e6c7bc24e9dfb22ea29cd3a
sha256sums = 3f7f448987c82b9475182cc2bf5b861780e9da2a121b3607c5d24bc836846e86
sha256sums = ff1993aff155370018deeb78a0a112e887394fe3c5d289140d17462d1c2f1cc6
pkgname = secureboot-helper
-
diff --git a/PKGBUILD b/PKGBUILD
index 09e1750903b6..a387666966d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _sign_location="etc/secureboot/keys"
# Maintainer: BrLi <brli@chakralinux.org>
pkgname=secureboot-helper
-pkgver=1.1.0
+pkgver=1.1.1
pkgrel=1
pkgdesc="Kernel signing helper for UEFI secure boot"
arch=('any')
@@ -32,19 +32,21 @@ backup=($_sign_location/db/db.auth
$_sign_location/PK/PK.key
$_sign_location/PK/rm_PK.auth
$_sign_location/GUID.txt)
-source=(secureboot-helper.hook
+source=(secureboot-helper-kernel.hook
secureboot-helper-systemd.hook
secureboot-helper-ucode.hook
systemd-boot-update.hook
secureboot-helper.sysusers)
sha256sums=('0e52f034ba8576b1723e07f974ea8a7d689cc41488cee731a6e0cb510a2cd4be'
'fa56188cb7d1175283ad7bbdc06a540ba8c1a2fc1b5ea55011a3a2cca0f7ac4c'
- '00cf821b99f5851aed9b1eff2cc242d651017ab3d164605541c66d817fbebadb'
+ 'badc4c0a167af7606df2076929d3ccede9da971b9e6c7bc24e9dfb22ea29cd3a'
'3f7f448987c82b9475182cc2bf5b861780e9da2a121b3607c5d24bc836846e86'
'ff1993aff155370018deeb78a0a112e887394fe3c5d289140d17462d1c2f1cc6')
prepare() {
- sed "s,%SIGN_LOCATION%,$_sign_location,g" -i $srcdir/secureboot-helper.hook
+ sed "s,%SIGN_LOCATION%,$_sign_location,g" -i $srcdir/secureboot-helper-kernel.hook
+ sed "s,%SIGN_LOCATION%,$_sign_location,g" -i $srcdir/secureboot-helper-systemd.hook
+ sed "s,%SIGN_LOCATION%,$_sign_location,g" -i $srcdir/secureboot-helper-ucode.hook
sed "s,%SIGN_LOCATION%,$_sign_location,g" -i $srcdir/secureboot-helper.sysusers
}
package() {
@@ -71,6 +73,7 @@ package() {
# Signature Database key
msg 'Generating DB.key'
+ cd $pkgdir/$_sign_location/db
openssl req -newkey rsa:2048 -nodes -keyout db.key -new -x509 -sha256 -days 3650 -subj "/CN=Self-generated Signature Database key/" -out db.crt
openssl x509 -outform DER -in db.crt -out db.cer
cert-to-efi-sig-list -g "$(< ../GUID.txt)" db.crt db.esl
diff --git a/secureboot-helper.hook b/secureboot-helper-kernel.hook
index 5cdcce80852c..5cdcce80852c 100644
--- a/secureboot-helper.hook
+++ b/secureboot-helper-kernel.hook