summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2022-01-07 12:20:39 +0100
committerChristian Hesse2022-01-07 12:20:39 +0100
commitcc33375167984f7e0b5eecb32d50734d768e456a (patch)
treefc66e2e56be0a3674d79b8b34a7ee116a86c26b4
downloadaur-cc33375167984f7e0b5eecb32d50734d768e456a.tar.gz
commit sedparse 0.1.2-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
2 files changed, 29 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..584d2ce6063d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = sedparse
+ pkgdesc = parser for sed scripts
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://github.com/aureliojargas/sedparse
+ arch = any
+ license = GPL
+ depends = python
+ source = sedparse-0.1.2.tar.gz::https://github.com/aureliojargas/sedparse/archive/refs/tags/0.1.2.tar.gz
+ sha256sums = 81b5c55da8104e54dfdd9ff43b06bfea040f9dabd9453ba44f10cc211389495d
+
+pkgname = sedparse
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d70e2d10f746
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+
+pkgname=sedparse
+pkgver=0.1.2
+pkgrel=1
+pkgdesc='parser for sed scripts'
+arch=('any')
+depends=('python')
+url='https://github.com/aureliojargas/sedparse'
+license=('GPL')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/aureliojargas/${pkgname}/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('81b5c55da8104e54dfdd9ff43b06bfea040f9dabd9453ba44f10cc211389495d')
+
+package() {
+ install -D -m0755 ${srcdir}/sedparse-${pkgver}/sedparse.py ${pkgdir}/usr/bin/sedparse
+}
+