summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMauro Santos2017-07-29 03:53:09 +0100
committerMauro Santos2017-07-29 03:53:09 +0100
commitd7aa8d4f3c463a0e4cb3e3c1d8c455e74f79a5ad (patch)
tree73c9495815d4c0fee43c2fecab8fb8748b1d0d57
parent7af0e2de853803b8fcd89c3ab93bf8c5f00b2fa3 (diff)
downloadaur-d7aa8d4f3c463a0e4cb3e3c1d8c455e74f79a5ad.tar.gz
Wait for one second and then use udevadm to wait until things settle.
This should result in more consistent results between the normal and fallback images and reduce wait time before asking for a password.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
-rwxr-xr-xlinuxpba-arch14
3 files changed, 7 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index adbb276afd4e..970c4afeeb42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Jul 23 11:53:46 UTC 2017
+# Sat Jul 29 02:53:09 UTC 2017
pkgbase = sedutil
pkgdesc = TCG OPAL 2.00 SED Management Program
pkgver = 1.12
@@ -30,7 +30,7 @@ pkgbase = sedutil
sha256sums = 40d785c16a28a5a8a43050d1731174482ee24459be215d2e4e27ffba3b2e28b2
sha256sums = 77c725e4eee095dbede512d2bca13b8f2c139a67b9b87a11d98be94e6df0e1d7
sha256sums = b860d4d6fcc14a61d110c1d805d919fdfcf0fffaa8f0175b5ecddf60051f7941
- sha256sums = 6aa4a9cb90da2d1b0f5eae6a9b487d6b7504d40b44ac62ec70edeef15ed40ee3
+ sha256sums = 6207ef94a25b5b86890f60e003a10686e9fc8705b7e071f7dd75080c14d8ee00
sha256sums = 6bf64faa4e413bac489e83518daf6963760cc4474ea2b848d0192402214c0efb
sha256sums = a110e6d6da0fd658412d8c79f7f2cbc58a9b0067c34c34c94c8f623801eecc78
sha256sums = d9a7b66d8365e7f4eb0233b30c0ab70b5e978f6554960bf12994a1f0910c1447
diff --git a/PKGBUILD b/PKGBUILD
index 232860a259f7..a7dcf0b697a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,7 +29,7 @@ sha256sums=('5509d4279cfb316f33730c5cb06f8162ae212c7f4d31d206642d67cc8be245c1'
'40d785c16a28a5a8a43050d1731174482ee24459be215d2e4e27ffba3b2e28b2'
'77c725e4eee095dbede512d2bca13b8f2c139a67b9b87a11d98be94e6df0e1d7'
'b860d4d6fcc14a61d110c1d805d919fdfcf0fffaa8f0175b5ecddf60051f7941'
- '6aa4a9cb90da2d1b0f5eae6a9b487d6b7504d40b44ac62ec70edeef15ed40ee3'
+ '6207ef94a25b5b86890f60e003a10686e9fc8705b7e071f7dd75080c14d8ee00'
'6bf64faa4e413bac489e83518daf6963760cc4474ea2b848d0192402214c0efb'
'a110e6d6da0fd658412d8c79f7f2cbc58a9b0067c34c34c94c8f623801eecc78'
'd9a7b66d8365e7f4eb0233b30c0ab70b5e978f6554960bf12994a1f0910c1447'
diff --git a/linuxpba-arch b/linuxpba-arch
index e14d751962fc..67888412c8a2 100755
--- a/linuxpba-arch
+++ b/linuxpba-arch
@@ -12,6 +12,9 @@ SED_PASSWD=""
echo ""
+sleep 1
+udevadm settle -t 10
+
if [[ -e "$KEYRING" ]]
then
@@ -19,6 +22,7 @@ then
if [[ -e "/usr/bin/ykchalresp" && -e "/usr/bin/ykinfo" ]]
then
+ udevadm settle -t 3
ykinfo -s &>/dev/null
if [[ $? -eq 0 ]]
then
@@ -49,16 +53,6 @@ then
fi
fi
- if [[ "x$SED_PASSWD" = "x" ]]
- then
- WAIT=6
- while [[ ! -b "$KFNAME" && "$WAIT" -gt 0 ]]
- do
- sleep 0.5
- let WAIT-=1
- done
- fi
-
if [[ -e "$KFNAME" && "x$SED_PASSWD" = "x" ]]
then
echo -n "Unlocking keyring with keyfile ... "