summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarti Raudsepp2009-10-27 11:57:18 +0200
committerMarti Raudsepp2009-10-27 11:57:18 +0200
commit98ae4907fdde67907385c656faa0d9aefcd88b17 (patch)
tree375d50c275627a0a2f184ca1227c0c3210bfbdbd
downloadaur-98ae4907fdde67907385c656faa0d9aefcd88b17.tar.gz
pkgbuilds: initial import.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD48
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f99eb50510b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = seekwatcher-hg
+ pkgdesc = Generates graphs from blktrace runs to help visualize IO patterns and performance
+ pkgver = 104
+ pkgrel = 1
+ url = http://oss.oracle.com/~mason/seekwatcher/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = mercurial
+ makedepends = python2
+ depends = python2-matplotlib
+ depends = python2-numpy
+ optdepends = blktrace: for tracing the local system
+ optdepends = pyqt3: enable interactive mode
+ optdepends = mencoder: enable video output
+ conflicts = seekwatcher
+
+pkgname = seekwatcher-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..44412eddc019
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Contributor: Marti Raudsepp <marti@juffo.org>
+pkgname=seekwatcher-hg
+pkgver=104
+pkgrel=1
+pkgdesc="Generates graphs from blktrace runs to help visualize IO patterns and performance"
+arch=(i686 x86_64)
+url="http://oss.oracle.com/~mason/seekwatcher/"
+license=('GPL')
+makedepends=('mercurial' 'python')
+depends=('python-matplotlib' 'python-numpy')
+optdepends=('blktrace: for tracing the local system')
+conflicts=('seekwatcher')
+md5sums=()
+
+_hgroot="http://oss.oracle.com/mercurial/mason/"
+_hgrepo="seekwatcher"
+
+build() {
+ cd $srcdir
+
+ if [ -d $_hgrepo/.hg ]; then
+ (cd $_hgrepo && hg up -r $pkgver)
+ else
+ hg clone -r $pkgver $_hgroot/$_hgrepo $_hgrepo
+ fi
+
+ msg "Mercurial checkout done or server timeout"
+
+ if [ -d $_hgrepo-build ]; then
+ msg "Removing old build directory"
+ rm -rf $_hgrepo-build
+ fi
+
+ msg "Copying repository to another build directory"
+ cp -r $srcdir/$_hgrepo $srcdir/$_hgrepo-build
+
+ msg "Starting build"
+ cd $srcdir/$_hgrepo-build
+
+ msg "Running setup.py"
+ python setup.py build || return 1
+ python setup.py install --root=$pkgdir || return 1
+
+ msg "Installing documentation"
+ install -dm 755 $pkgdir/usr/share/doc/seekwatcher
+ cp -r $srcdir/$_hgrepo-build/README.html $pkgdir/usr/share/doc/seekwatcher
+}
+