summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2019-08-23 15:18:06 +0200
committerbartus2019-08-23 15:18:06 +0200
commit6ff4e1a75270c65cd52a279659d6aa618ecedfff (patch)
tree34bfae18ce69f4411a2ebc32287affbab9e6c9bb
parent306c54074198e10d59588187f937510b1fad5ebe (diff)
downloadaur-6ff4e1a75270c65cd52a279659d6aa618ecedfff.tar.gz
Update to v3.0.0
* add gtest * add llvm * add python-boost * drop build.patch * drop prepare()
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD33
-rw-r--r--build.patch44
3 files changed, 29 insertions, 72 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1b7e4a0335f..6d02c0eb904b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,30 @@
pkgbase = seexpr
pkgdesc = An embeddable expression evaluation engine
- pkgver = 2.11
+ pkgver = 3.0.0
pkgrel = 1
- url = http://www.disneyanimation.com/technology/seexpr.html
+ url = https://www.disneyanimation.com/technology/seexpr.html
arch = i686
arch = x86_64
license = custom:Apache
- makedepends = python2-pyqt4
+ makedepends = boost
+ makedepends = llvm
+ makedepends = python-pyqt5
makedepends = doxygen
makedepends = libpng
makedepends = cmake
makedepends = git
- makedepends = python2-sip
- depends = python2
- depends = qt4
- optdepends = python2-pyqt4: Editor support
+ makedepends = sip
+ makedepends = python-sip
+ makedepends = gtest
+ depends = python
+ depends = llvm-libs
+ depends = qt5-base
+ optdepends = python-pyqt5: Editor support
+ optdepends = boost-libs: Python bindings
provides = seexpr
conflicts = seexpr
- source = git+https://github.com/wdas/SeExpr.git#tag=v2.11
- source = build.patch
+ source = git+https://github.com/wdas/SeExpr.git#tag=v3.0.0
md5sums = SKIP
- md5sums = ad7a72d539fbb5b899f26f7fd1cfc950
pkgname = seexpr
diff --git a/PKGBUILD b/PKGBUILD
index cbe5f1b6e430..ac54c6906c0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,34 @@
# Maintainer : bartus <arch-user-repoᘓbartus.33mail.com>
pkgname=('seexpr' 'seexpr-doc')
-_fragment="#tag=v2.11"
-pkgver=2.11
+_fragment="#tag=v3.0.0"
+pkgver=3.0.0
pkgrel=1
pkgdesc="An embeddable expression evaluation engine"
arch=('i686' 'x86_64')
-url="http://www.disneyanimation.com/technology/seexpr.html"
+url="https://www.disneyanimation.com/technology/seexpr.html"
license=('custom:Apache')
-depends=('python2' 'qt4')
-optdepends=('python2-pyqt4: Editor support')
-#makedepends=('python2-pyqt4' 'doxygen' 'glew' 'libpng' 'cmake>=2.4.6' 'git' 'python-sip' 'boost' 'llvm')
-makedepends=('python2-pyqt4' 'doxygen' 'libpng' 'cmake' 'git' 'python2-sip')
+depends=('python' 'llvm-libs' 'qt5-base')
+optdepends=('python-pyqt5: Editor support')
+optdepends+=('boost-libs: Python bindings')
+makedepends=('boost' 'llvm' 'python-pyqt5' 'doxygen' 'libpng' 'cmake' 'git' 'sip' 'python-sip' 'gtest')
provides=("${pkgname}")
conflicts=("${pkgname}")
-source=("git+https://github.com/wdas/SeExpr.git${_fragment}"
- "build.patch")
-md5sums=('SKIP'
- 'ad7a72d539fbb5b899f26f7fd1cfc950')
-
-prepare() {
- cd ${srcdir}/SeExpr
- sed -i 's/env python/env python2/' src/build/build-info
- patch -Np1 -i ../build.patch
-}
+source=("git+https://github.com/wdas/SeExpr.git${_fragment}")
+md5sums=('SKIP')
build() {
cd "$srcdir/SeExpr"
mkdir -p build
cd build
- cmake -DCMAKE_INSTALL_PREFIX='/usr' -DCMAKE_INSTALL_LIBDIR='/usr/lib' ..
+ cmake -DCMAKE_INSTALL_PREFIX='/usr' -DCMAKE_INSTALL_LIBDIR='/usr/lib' -DPYQT_SIP_DIR='/usr/share/sip/PyQt5' -DENABLE_SLOW_TESTS=ON ..
make
}
+check() {
+ cd "$srcdir/SeExpr/build"
+ make test
+}
+
package_seexpr() {
cd "$srcdir/SeExpr/build"
make DESTDIR="$pkgdir/" install
diff --git a/build.patch b/build.patch
deleted file mode 100644
index 0ff2c64c0dc9..000000000000
--- a/build.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff --git a/src/build/build-info b/src/build/build-info
-index ddc9d77..979fa14 100755
---- a/src/build/build-info
-+++ b/src/build/build-info
-@@ -11,7 +11,7 @@ if 'MACOSX_DEPLOYMENT_TARGET' in os.environ:
- from distutils import sysconfig as sc
-
- import sipconfig
--from PyQt4 import pyqtconfig
-+#from PyQt4 import pyqtconfig
-
- def main():
- parser = argparse.ArgumentParser()
-@@ -55,8 +55,7 @@ def python_site(args):
-
-
- def pyqt4_sip(args):
-- pkg_cfg = pyqtconfig._pkg_config
-- return pkg_cfg['pyqt_sip_dir']
-+ return os.path.join(sipconfig.Configuration().default_sip_dir, 'PyQt4')
-
-
- def sip_inc(args):
-diff --git a/src/SeExprEditor/CMakeLists.txt b/src/SeExprEditor/CMakeLists.txt
-index 33c6cab..2b98580 100644
---- a/src/SeExprEditor/CMakeLists.txt
-+++ b/src/SeExprEditor/CMakeLists.txt
-@@ -13,9 +13,11 @@
- # You may obtain a copy of the License at
- # http://www.apache.org/licenses/LICENSE-2.0
-
-+set(Python_ADDITIONAL_VERSIONS 2.7 2.6 2.5 2.4)
- find_package(PythonInterp)
- find_package(PythonLibs)
-
-+if(PYTHONLIBS_FOUND)
- macro(get_build_info NAME STORAGE)
- execute_process(
- COMMAND ${PYTHON_EXECUTABLE} ${PROJECT_SOURCE_DIR}/src/build/build-info ${NAME}
-@@ -118,3 +120,4 @@ ENDIF(WIN32)
- DESTINATION ${CMAKE_INSTALL_PYTHON})
-
- endif(QT4_FOUND)
-+endif(PYTHONLIBS_FOUND)