summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2017-09-22 18:00:27 +0200
committerbartus2017-09-22 18:00:27 +0200
commitc7fe8d16bf508e7351b13310234ae8ff67908cea (patch)
tree3bad2bb24bce287a528d44c1fa691f1ee9cdfbba
downloadaur-c7fe8d16bf508e7351b13310234ae8ff67908cea.tar.gz
initial
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD57
-rw-r--r--build.patch44
3 files changed, 134 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d1b7e4a0335f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = seexpr
+ pkgdesc = An embeddable expression evaluation engine
+ pkgver = 2.11
+ pkgrel = 1
+ url = http://www.disneyanimation.com/technology/seexpr.html
+ arch = i686
+ arch = x86_64
+ license = custom:Apache
+ makedepends = python2-pyqt4
+ makedepends = doxygen
+ makedepends = libpng
+ makedepends = cmake
+ makedepends = git
+ makedepends = python2-sip
+ depends = python2
+ depends = qt4
+ optdepends = python2-pyqt4: Editor support
+ provides = seexpr
+ conflicts = seexpr
+ source = git+https://github.com/wdas/SeExpr.git#tag=v2.11
+ source = build.patch
+ md5sums = SKIP
+ md5sums = ad7a72d539fbb5b899f26f7fd1cfc950
+
+pkgname = seexpr
+
+pkgname = seexpr-doc
+ arch = any
+ depends =
+ optdepends =
+ provides =
+ conflicts =
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1bdf5008866c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: bartus <aur@bartus.33mail.com>
+pkgname=('seexpr' 'seexpr-doc')
+_fragment="#tag=v2.11"
+pkgver=2.11
+pkgrel=1
+pkgdesc="An embeddable expression evaluation engine"
+arch=('i686' 'x86_64')
+url="http://www.disneyanimation.com/technology/seexpr.html"
+license=('custom:Apache')
+depends=('python2' 'qt4')
+optdepends=('python2-pyqt4: Editor support')
+#makedepends=('python2-pyqt4' 'doxygen' 'glew' 'libpng' 'cmake>=2.4.6' 'git' 'python-sip' 'boost' 'llvm')
+makedepends=('python2-pyqt4' 'doxygen' 'libpng' 'cmake' 'git' 'python2-sip')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+source=("git+https://github.com/wdas/SeExpr.git${_fragment}"
+ "build.patch")
+md5sums=('SKIP'
+ 'ad7a72d539fbb5b899f26f7fd1cfc950')
+
+prepare() {
+ cd ${srcdir}/SeExpr
+ sed -i 's/env python/env python2/' src/build/build-info
+ patch -Np1 -i ../build.patch
+}
+
+build() {
+ cd "$srcdir/SeExpr"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX='/usr' -DCMAKE_INSTALL_LIBDIR='/usr/lib' ..
+ make
+}
+
+package_seexpr() {
+ cd "$srcdir/SeExpr/build"
+ make DESTDIR="$pkgdir/" install
+ # remove doc
+ mkdir -p ${pkgdir}/../tmp/usr/share/
+ mv ${pkgdir}/usr/share/doc ${pkgdir}/../tmp/usr/share/
+ # Copy custom Apache license
+ install -D -m644 "../LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+package_seexpr-doc() {
+#reset defs
+ arch=('any')
+ depends=()
+ optdepends=()
+ provides=()
+ conflicts=()
+
+ cd ${srcdir}/SeExpr/build
+ mkdir -p ${pkgdir}/usr/share/
+ mv ${pkgdir}/../tmp/usr/share/doc ${pkgdir}/usr/share/
+ install -D -m644 "../LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/build.patch b/build.patch
new file mode 100644
index 000000000000..0ff2c64c0dc9
--- /dev/null
+++ b/build.patch
@@ -0,0 +1,44 @@
+diff --git a/src/build/build-info b/src/build/build-info
+index ddc9d77..979fa14 100755
+--- a/src/build/build-info
++++ b/src/build/build-info
+@@ -11,7 +11,7 @@ if 'MACOSX_DEPLOYMENT_TARGET' in os.environ:
+ from distutils import sysconfig as sc
+
+ import sipconfig
+-from PyQt4 import pyqtconfig
++#from PyQt4 import pyqtconfig
+
+ def main():
+ parser = argparse.ArgumentParser()
+@@ -55,8 +55,7 @@ def python_site(args):
+
+
+ def pyqt4_sip(args):
+- pkg_cfg = pyqtconfig._pkg_config
+- return pkg_cfg['pyqt_sip_dir']
++ return os.path.join(sipconfig.Configuration().default_sip_dir, 'PyQt4')
+
+
+ def sip_inc(args):
+diff --git a/src/SeExprEditor/CMakeLists.txt b/src/SeExprEditor/CMakeLists.txt
+index 33c6cab..2b98580 100644
+--- a/src/SeExprEditor/CMakeLists.txt
++++ b/src/SeExprEditor/CMakeLists.txt
+@@ -13,9 +13,11 @@
+ # You may obtain a copy of the License at
+ # http://www.apache.org/licenses/LICENSE-2.0
+
++set(Python_ADDITIONAL_VERSIONS 2.7 2.6 2.5 2.4)
+ find_package(PythonInterp)
+ find_package(PythonLibs)
+
++if(PYTHONLIBS_FOUND)
+ macro(get_build_info NAME STORAGE)
+ execute_process(
+ COMMAND ${PYTHON_EXECUTABLE} ${PROJECT_SOURCE_DIR}/src/build/build-info ${NAME}
+@@ -118,3 +120,4 @@ ENDIF(WIN32)
+ DESTINATION ${CMAKE_INSTALL_PYTHON})
+
+ endif(QT4_FOUND)
++endif(PYTHONLIBS_FOUND)