summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormeepzh2016-06-03 18:16:29 -0400
committermeepzh2016-06-03 18:18:09 -0400
commitea5142b064dd3e634175ae25a9105f17f6843f9f (patch)
tree6e5ec04370c049885c21cff6c7a775e9fd5eb99a
downloadaur-ea5142b064dd3e634175ae25a9105f17f6843f9f.tar.gz
Initial commit, version 2.9.r0.g36ffb81
-rw-r--r--.SRCINFO24
-rw-r--r--CMakeLists.txt.patch9
-rw-r--r--Editor_CMakeLists.txt.patch18
-rw-r--r--PKGBUILD46
-rw-r--r--build-info.patch20
5 files changed, 117 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..06b81303754c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = seexpr-git
+ pkgdesc = An embeddable expression evaluation engine
+ pkgver = 2.9.r0.g36ffb81
+ pkgrel = 1
+ url = http://www.disneyanimation.com/technology/seexpr.html
+ arch = i686
+ arch = x86_64
+ license = custom:SeExpr
+ makedepends = cmake>=2.4.6
+ makedepends = git
+ optdepends = python2-pyqt4: required for SeExpr editor
+ provides = seexpr
+ conflicts = seexpr
+ source = git+https://github.com/wdas/SeExpr.git
+ source = build-info.patch
+ source = CMakeLists.txt.patch
+ source = Editor_CMakeLists.txt.patch
+ md5sums = SKIP
+ md5sums = bb56b587bca21debebf86b7adb6242f1
+ md5sums = 0b04cc77edebf6d364767cad0a988ef2
+ md5sums = 69721fc7e11747cfbc7f0712b4975f79
+
+pkgname = seexpr-git
+
diff --git a/CMakeLists.txt.patch b/CMakeLists.txt.patch
new file mode 100644
index 000000000000..9a78766f31a5
--- /dev/null
+++ b/CMakeLists.txt.patch
@@ -0,0 +1,9 @@
+--- /SeExpr/CMakeLists.txt 2016-06-03 17:23:09.148872767 -0400
++++ /SeExpr/CMakeLists.txt 2016-06-03 17:24:26.255300396 -0400
+@@ -97,6 +97,3 @@
+ ## Traverse subdirectories
+ ADD_SUBDIRECTORY (src/SeExpr)
+ ADD_SUBDIRECTORY (src/SeExprEditor)
+-ADD_SUBDIRECTORY (src/doc)
+-ADD_SUBDIRECTORY (src/demos)
+-ADD_SUBDIRECTORY (src/tests)
diff --git a/Editor_CMakeLists.txt.patch b/Editor_CMakeLists.txt.patch
new file mode 100644
index 000000000000..ff5bb2c3dafb
--- /dev/null
+++ b/Editor_CMakeLists.txt.patch
@@ -0,0 +1,18 @@
+--- /SeExpr/src/SeExprEditor/CMakeLists.txt 2016-06-03 17:31:57.167238683 -0400
++++ /SeExpr/src/SeExprEditor/CMakeLists.txt 2016-06-03 17:47:57.927613878 -0400
+@@ -13,8 +13,10 @@
+ # You may obtain a copy of the License at
+ # http://www.apache.org/licenses/LICENSE-2.0
+
++set(Python_ADDITIONAL_VERSIONS 2.7 2.6 2.5 2.4)
+ find_package(PythonInterp)
+ find_package(PythonLibs)
++if(PYTHONLIBS_FOUND)
+
+ macro(get_build_info NAME STORAGE)
+ execute_process(
+@@ -118,3 +120,4 @@
+ DESTINATION ${CMAKE_INSTALL_PYTHON})
+
+ endif(QT4_FOUND)
++endif(PYTHONLIBS_FOUND)
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..500a16b42d2f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: meepzh <meep.aur@meepzh.com>
+pkgname=seexpr-git
+pkgver=2.9.r0.g36ffb81
+pkgrel=1
+pkgdesc="An embeddable expression evaluation engine"
+arch=(i686 x86_64)
+url="http://www.disneyanimation.com/technology/seexpr.html"
+license=('custom:SeExpr')
+optdepends=('python2-pyqt4: required for SeExpr editor')
+makedepends=('cmake>=2.4.6' 'git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/wdas/SeExpr.git' 'build-info.patch' 'CMakeLists.txt.patch' 'Editor_CMakeLists.txt.patch')
+md5sums=('SKIP' 'bb56b587bca21debebf86b7adb6242f1' '0b04cc77edebf6d364767cad0a988ef2' '69721fc7e11747cfbc7f0712b4975f79')
+
+pkgver() {
+ cd "$srcdir/SeExpr"
+ # Cutting off 'v' prefix that presents in the git tag
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir"
+ # Remove pyqtconfig module dependency
+ patch -p1 -i "$srcdir/build-info.patch"
+ # Remove demos, tests, and docs
+ patch -p1 -i "$srcdir/CMakeLists.txt.patch"
+ # Use Python2 for editor if available
+ patch -p1 -i "$srcdir/Editor_CMakeLists.txt.patch"
+}
+
+build() {
+ cd "$srcdir/SeExpr"
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd "$srcdir/SeExpr/build"
+ make DESTDIR="$pkgdir/" install
+ # Copy custom Apache license
+ mkdir -p "$pkgdir/usr/share/licenses/${pkgname}"
+ cp "../LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/build-info.patch b/build-info.patch
new file mode 100644
index 000000000000..cbb3bd31d32f
--- /dev/null
+++ b/build-info.patch
@@ -0,0 +1,20 @@
+--- /SeExpr/src/build/build-info 2016-06-03 12:54:07.200156578 -0400
++++ /SeExpr/src/build/build-info 2016-06-03 14:32:59.060643373 -0400
+@@ -11,7 +11,6 @@
+ from distutils import sysconfig as sc
+
+ import sipconfig
+-from PyQt4 import pyqtconfig
+
+ def main():
+ parser = argparse.ArgumentParser()
+@@ -55,8 +54,7 @@
+
+
+ def pyqt4_sip(args):
+- pkg_cfg = pyqtconfig._pkg_config
+- return pkg_cfg['pyqt_sip_dir']
++ return os.path.join(sipconfig.Configuration().default_sip_dir, 'PyQt4')
+
+
+ def sip_inc(args):