summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2019-03-26 22:45:11 +0100
committerbartus2019-03-26 22:45:11 +0100
commit734e8704e4f4957e2a2f6e37eb95dfcb1df591d3 (patch)
treeb1100fc20bc08fe1f7fa446d836bead972e6f318
downloadaur-734e8704e4f4957e2a2f6e37eb95dfcb1df591d3.tar.gz
init
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD69
-rw-r--r--llvm.patch48
3 files changed, 151 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d75b67f223f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = seexpr2
+ pkgdesc = An embeddable expression evaluation engine
+ pkgver = 1.11.4
+ pkgrel = 1
+ url = http://www.disneyanimation.com/technology/seexpr.html
+ arch = i686
+ arch = x86_64
+ license = custom:Apache
+ makedepends = boost
+ makedepends = cmake
+ makedepends = doxygen
+ makedepends = git
+ makedepends = llvm
+ makedepends = libpng
+ makedepends = python-pyqt5
+ makedepends = python-sip
+ makedepends = sip
+ depends = python
+ depends = boost-libs
+ depends = qt5-base
+ source = git+https://github.com/wdas/SeExpr.git#tag=v2-1.11.4
+ source = llvm.patch
+ md5sums = SKIP
+ md5sums = 3d70da8447176865505d36e9a86a2b70
+
+pkgname = seexpr2
+
+pkgname = seexpr2-doc
+ arch = any
+ depends =
+ optdepends =
+ provides =
+ conflicts =
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc0cf7727ba7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,69 @@
+# Maintainer : bartus <arch-user-repoᘓbartus.33mail.com>
+
+pkgname=('seexpr2' 'seexpr2-doc')
+_fragment="#tag=v2-1.11.4"
+pkgver=1.11.4
+pkgrel=1
+pkgdesc="An embeddable expression evaluation engine"
+arch=('i686' 'x86_64')
+url="http://www.disneyanimation.com/technology/seexpr.html"
+license=('custom:Apache')
+depends=('python' 'boost-libs' 'llvm-libs' 'qt5-base')
+#makedepends=('python2-pyqt4' 'doxygen' 'glew' 'libpng' 'cmake>=2.4.6' 'git' 'python-sip' 'boost' 'llvm')
+makedepends=('boost' 'cmake' 'doxygen' 'git' 'llvm' 'libpng' 'python-pyqt5' 'python-sip' 'sip')
+source=("git+https://github.com/wdas/SeExpr.git${_fragment}"
+ "llvm.patch")
+md5sums=('SKIP'
+ '3d70da8447176865505d36e9a86a2b70')
+
+_CMAKE_FLAGS=( -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_INSTALL_LIBDIR='lib' \
+ -DENABLE_QT5=true \
+ -DPYQT_SIP_DIR=/usr/share/sip/PyQt5 \
+ -DOpenGL_GL_PREFERENCE=GLVND \
+ )
+# -DPNG_DIR=/usr \
+# -DLLVM_DIR=/usr/lib/cmake/llvm \
+# -DGTEST_DIR=/usr \
+# -DUSE_PYTHON=ON \
+# -DBOOST_DIR=${BOOST} \
+# -DCUSTOM_PYTHON_FRAMEWORK=${CUSTOM_PYTHON_FRAMEWORK} \
+
+prepare() {
+ cd ${srcdir}/SeExpr
+ patch -Np1 -i ../llvm.patch
+}
+
+build() {
+ cd "$srcdir/SeExpr"
+ mkdir -p build && cd build
+ cmake ${_CMAKE_FLAGS[@]} ..
+ make
+ #cp Makefile.config.example Makefile.config
+ #make RP_qt5=true PR_pyqt5=true
+}
+
+package_seexpr2() {
+ cd "$srcdir/SeExpr/build"
+ make DESTDIR="$pkgdir/" install
+ # move doc to next package
+ mkdir -p ${pkgdir}/../tmp/usr/share/
+ mv ${pkgdir}/usr/share/doc ${pkgdir}/../tmp/usr/share/
+ # Copy custom Apache license
+ install -D -m644 "../LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+package_seexpr2-doc() {
+#reset defs
+ arch=('any')
+ depends=()
+ optdepends=()
+ provides=()
+ conflicts=()
+
+ cd ${srcdir}/SeExpr/build
+ mkdir -p ${pkgdir}/usr/share/
+ mv ${pkgdir}/../tmp/usr/share/doc ${pkgdir}/usr/share/
+ # Copy custom Apache license
+ install -D -m644 "../LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/llvm.patch b/llvm.patch
new file mode 100644
index 000000000000..d9b3d71b2744
--- /dev/null
+++ b/llvm.patch
@@ -0,0 +1,48 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 1108aa2..049e0b7 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -88,7 +88,7 @@ set(LLVM_LIB "")
+ if (ENABLE_LLVM_BACKEND)
+ set(LLVM_DIR /usr/share/llvm/cmake CACHE PATH "Where to search for LLVM i.e. ")
+
+- find_package(LLVM CONFIG NAMES LLVM CONFIGS LLVM-Config.cmake LLVMConfig.cmake)
++ find_package(LLVM)
+ if (LLVM_FOUND)
+ set(SEEXPR_ENABLE_LLVM_BACKEND 1)
+ message(STATUS "Using LLVMConfig.cmake in: ${LLVM_DIR}")
+diff --git a/src/SeExpr/Evaluator.h b/src/SeExpr/Evaluator.h
+index 213ccba..5d82fa5 100644
+--- a/src/SeExpr/Evaluator.h
++++ b/src/SeExpr/Evaluator.h
+@@ -172,7 +172,7 @@ class LLVMEvaluator {
+ };
+ FunctionType *FT = FunctionType::get(voidTy, ParamTys, false);
+ Function *F = Function::Create(FT, Function::ExternalLinkage, uniqueName + "_func", TheModule.get());
+- F->addAttribute(llvm::AttributeSet::FunctionIndex, llvm::Attribute::AlwaysInline);
++ F->addAttribute(llvm::AttributeList::FunctionIndex, llvm::Attribute::AlwaysInline);
+ {
+ // label the function with names
+ const char *names[] = {"outputPointer", "dataBlock", "indirectIndex"};
+@@ -288,8 +288,10 @@ class LLVMEvaluator {
+ }
+
+ if (Expression::debugging) {
++ #ifdef DEBUG
+ std::cerr << "Pre verified LLVM byte code " << std::endl;
+ TheModule->dump();
++ #endif
+ }
+
+ // TODO: Find out if there is a new way to veirfy
+@@ -361,8 +363,10 @@ class LLVMEvaluator {
+ }
+
+ if (Expression::debugging) {
++ #ifdef DEBUG
+ std::cerr << "Pre verified LLVM byte code " << std::endl;
+ altModule->dump();
++ #endif
+ }
+
+ return true;