summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJon Wiersma2019-04-05 20:28:39 -0700
committerJon Wiersma2019-04-05 20:28:39 -0700
commitaf9060992459a0a9b8cdea733f8b3bdf8fabafcc (patch)
tree948eafda014f451d62879a517174a5bb0a779148
downloadaur-af9060992459a0a9b8cdea733f8b3bdf8fabafcc.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b4aa21bc86ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = segyio
+ pkgdesc = Library for easy interaction with SEG-Y formatted seismic data with bindings for Python and Matlab
+ pkgver = 1.8.3
+ pkgrel = 1
+ url = https://github.com/equinor/segyio
+ arch = x86_64
+ license = lgpl
+ makedepends = cmake
+ makedepends = python-setuptools>=28
+ makedepends = python-setuptools-scm
+ makedepends = python-pytest
+ depends = python>=2.7
+ depends = python-numpy>=1.10
+ optdepends = python-sphinx: to build the documentation
+ source = https://github.com/equinor/segyio/releases/download/1.8.3/segyio-1.8.3.tar.gz
+ md5sums = 0a68792d1d7215b4f48ad735aa3d39fb
+
+pkgname = segyio
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e39db1d85520
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Jon Wiersma (archaur at jonw dot org)
+pkgname='segyio'
+pkgdesc='Library for easy interaction with SEG-Y formatted seismic data with bindings for Python and Matlab'
+pkgver='1.8.3'
+pkgrel='1'
+arch=('x86_64')
+url='https://github.com/equinor/segyio'
+license=('lgpl')
+depends=(
+ 'python>=2.7'
+ 'python-numpy>=1.10'
+)
+makedepends=(
+ 'cmake'
+ 'python-setuptools>=28'
+ 'python-setuptools-scm'
+ 'python-pytest'
+)
+optdepends=(
+ 'python-sphinx: to build the documentation'
+)
+source=("https://github.com/equinor/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz")
+
+build() {
+ cd "$pkgname-$pkgver"
+ mkdir build
+ cd build
+ cmake .. -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_LIBDIR=/usr/lib -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver/build"
+ make DESTDIR="$pkgdir/" install
+}
+
+md5sums=('0a68792d1d7215b4f48ad735aa3d39fb')