summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFernandez Ludovic2019-05-09 22:48:46 +0200
committerFernandez Ludovic2019-05-09 22:48:46 +0200
commita0e6a4584a3b63bb098000d8eb7256d34138457b (patch)
tree43bcba066e47b044bd10208db1e796cc07724152
downloadaur-a0e6a4584a3b63bb098000d8eb7256d34138457b.tar.gz
feat: v0.4.0
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..986295d2f3cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = seihon
+ pkgdesc = A simple tool to publish multi-arch images on the Docker Hub.
+ pkgver = v0.4.0
+ pkgrel = 1
+ url = https://github.com/ldez/seihon
+ arch = x86_64
+ arch = i686
+ arch = aarch64
+ license = APACHE
+ source_x86_64 = https://github.com/ldez/seihon/releases/download/v0.4.0/seihon_v0.4.0_linux_amd64.tar.gz
+ sha256sums_x86_64 = 5b59dbb3b9099dec9d4a503e874b4c0f19ed3eb03f960eb8bf938059113050f5
+
+pkgname = seihon
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9817a6930629
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Fernandez Ludovic <lfernandez dot dev at gmail dot com>
+
+pkgname='seihon'
+pkgver=v0.4.0
+pkgrel=1
+pkgdesc='A simple tool to publish multi-arch images on the Docker Hub.'
+url='https://github.com/ldez/seihon'
+arch=('x86_64' 'i686' 'aarch64')
+license=('APACHE')
+
+depends=()
+makedepends=()
+optdepends=()
+
+_basedownloadurl="https://github.com/ldez/${pkgname}/releases/download/${pkgver}"
+_basearchive="${pkgname}_${pkgver}_linux"
+
+source_x86_64=("${_basedownloadurl}/${_basearchive}_amd64.tar.gz")
+sha256sums_x86_64=('5b59dbb3b9099dec9d4a503e874b4c0f19ed3eb03f960eb8bf938059113050f5')
+
+package() {
+ # Bin
+ rm -f "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+
+ # License
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}