summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2022-01-16 20:37:09 +0330
committerMohammadreza Abdollahzadeh2022-01-16 20:37:09 +0330
commitf23eae2cec1689eea8df7b68d07c4b76800e2ba2 (patch)
tree9c35bb3a90e37aaea74f89267728d6c8fcb06c51
parent8bfef469642fa33134b2df4f0f7212d752d28348 (diff)
downloadaur-f23eae2cec1689eea8df7b68d07c4b76800e2ba2.tar.gz
update to v4.8.3
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD19
-rw-r--r--seiscomp-sysusers.conf4
-rw-r--r--seiscomp.install8
4 files changed, 19 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd282fe00339..8e4263e9efda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = seiscomp-git
pkgdesc = A seismological software for data acquisition, processing, distribution and interactive analysis (GitHub version).
- pkgver = 4.8.2.r0.g36dc05e
+ pkgver = 4.8.3.r0.gb1f2c7d
pkgrel = 1
url = https://github.com/SeisComP
install = seiscomp.install
@@ -28,6 +28,7 @@ pkgbase = seiscomp-git
depends = qt5-svg
depends = sqlite
optdepends = seiscomp-maps: for SeisComp default map files
+ optdepends = nmxptool: for seedlink nmxp plugin
optdepends = postgresql: for using PostgreSQL database
provides = seiscomp
provides = seiscomp-docs
@@ -53,7 +54,7 @@ pkgbase = seiscomp-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = e8195d8cebe4a134d6054fb3cbf6fea9e5284d96192c957c9079059e4b463016
- sha256sums = 4cdce628264921efa947ddccba19cf5fd2d6af21a9b23e6fbe8972558a27f182
+ sha256sums = be8a26d9ac60c17b1ee56207f82e7e3ca5c5c2249ab24ce75c4ac25f952a0ee1
sha256sums = 312911098291e60a40d4f3fd455b9a40b2d9b3489a589fb927fb6fc0b9ac2dd2
pkgname = seiscomp-git
diff --git a/PKGBUILD b/PKGBUILD
index 93ec9eb8e770..8cd2f09dd635 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
pkgname=seiscomp-git
-pkgver=4.8.2.r0.g36dc05e
+pkgver=4.8.3.r0.gb1f2c7d
pkgrel=1
pkgdesc="A seismological software for data acquisition, processing, distribution and interactive analysis (GitHub version)."
arch=('x86_64')
@@ -9,6 +9,7 @@ license=('AGPL3')
depends=('boost-libs' 'inetutils' 'libxml2' 'mariadb' 'ncurses' 'openssl' 'python' 'python-dateutil' 'python-numpy' 'python-twisted' 'qt5-base' 'qt5-svg' 'sqlite')
makedepends=('boost' 'cmake' 'gcc-fortran' 'git' 'libmariadbclient' 'python-myst-parser' 'python-sphinx' 'postgresql-libs')
optdepends=("${pkgname%-git}-maps: for SeisComp default map files"
+ "nmxptool: for seedlink nmxp plugin"
"postgresql: for using PostgreSQL database")
provides=("${pkgname%-git}" "${pkgname%-git}-docs")
conflicts=("${pkgname%-git}" "${pkgname%-git}-docs")
@@ -33,7 +34,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'e8195d8cebe4a134d6054fb3cbf6fea9e5284d96192c957c9079059e4b463016'
- '4cdce628264921efa947ddccba19cf5fd2d6af21a9b23e6fbe8972558a27f182'
+ 'be8a26d9ac60c17b1ee56207f82e7e3ca5c5c2249ab24ce75c4ac25f952a0ee1'
'312911098291e60a40d4f3fd455b9a40b2d9b3489a589fb927fb6fc0b9ac2dd2')
scmodules=('seedlink' 'common' 'main' 'extras' 'contrib-gns' 'contrib-ipgp' 'contrib-sed')
@@ -79,14 +80,18 @@ build() {
package() {
cd "${pkgname%-git}/build"
make DESTDIR="${pkgdir}/" install
- install -D -m 644 "../src/system/apps/${pkgname%-git}/share/shell-completion/${pkgname%-git}.bash" \
+ cd "${srcdir}/${pkgname%-git}/src/system/apps/${pkgname%-git}/share/shell-completion"
+ install -D -m 644 "${pkgname%-git}.bash" \
"${pkgdir}/usr/share/bash-completion/completions/${pkgname%-git}"
- install -D -m 644 "../src/system/apps/${pkgname%-git}/share/shell-completion/${pkgname%-git}.fish" \
+ install -D -m 644 "${pkgname%-git}.fish" \
"${pkgdir}/usr/share/fish/vendor_completions.d/${pkgname%-git}.fish"
cd ${srcdir}
install -D -t "${pkgdir}/etc/profile.d/" -m 755 "${pkgname%-git}.sh"
- install -D -m 644 "${pkgname%-git}-sysusers.conf" "${pkgdir}/usr/lib/sysusers.d/${pkgname%-git}.conf"
- install -D -m 644 "${pkgname%-git}-tmpfiles.conf" "${pkgdir}/usr/lib/tmpfiles.d/${pkgname%-git}.conf"
- chmod -R g+w "${pkgdir}/opt/${pkgname%-git}"
+ install -D -m 644 "${pkgname%-git}-sysusers.conf" \
+ "${pkgdir}/usr/lib/sysusers.d/${pkgname%-git}.conf"
+ install -D -m 644 "${pkgname%-git}-tmpfiles.conf" \
+ "${pkgdir}/usr/lib/tmpfiles.d/${pkgname%-git}.conf"
+ chmod -R u=rwX,g=rwX,o=rX "${pkgdir}/opt/${pkgname%-git}"
+ find "${pkgdir}/opt/${pkgname%-git}" -type d -exec chmod g+s '{}' \;
}
# vim:set ts=4 sw=4 et:
diff --git a/seiscomp-sysusers.conf b/seiscomp-sysusers.conf
index aa2bd0ef43c0..a5f9b5f67a8d 100644
--- a/seiscomp-sysusers.conf
+++ b/seiscomp-sysusers.conf
@@ -1,2 +1,2 @@
-#Type Name ID GECOS Home directory Shell
-u seiscomp - "SeisComp" - -
+#Type Name ID GECOS Home directory Shell
+u seiscomp - "SeisComP Seismological Software" /opt/seiscomp -
diff --git a/seiscomp.install b/seiscomp.install
index f626407ee9d4..3421d07aa044 100644
--- a/seiscomp.install
+++ b/seiscomp.install
@@ -1,7 +1,5 @@
post_install() {
- find opt/seiscomp -type d \
- -exec setfacl -d -m g::rwX '{}' \; \
- -exec chmod g+s '{}' \;
+ find opt/seiscomp -type d -exec setfacl -d -m g::rwX '{}' \;
echo " ->----------------------------------------------------------------<-"
echo " -> Before using seiscomp for first time you need to do following:"
@@ -12,7 +10,5 @@ post_install() {
}
post_upgrade() {
- find opt/seiscomp -type d \
- -exec setfacl -d -m g::rwX '{}' \; \
- -exec chmod g+s '{}' \;
+ find opt/seiscomp -type d -exec setfacl -d -m g::rwX '{}' \;
}