summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2022-01-06 12:00:38 +0330
committerMohammadreza Abdollahzadeh2022-01-06 12:00:38 +0330
commit6a19470b0573001d397a6839853027a4dc4f437d (patch)
tree1420bbf1fa6c81a143085452c5e93ce9e5c15ed6
downloadaur-6a19470b0573001d397a6839853027a4dc4f437d.tar.gz
initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
-rw-r--r--seiscomp-maps-tmpfiles.conf2
-rw-r--r--seiscomp-maps.install9
4 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a728f4379d49
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = seiscomp-maps
+ pkgdesc = SeisComp map files.
+ pkgver = 4.8.2
+ pkgrel = 1
+ url = https://www.seiscomp.de
+ install = seiscomp-maps.install
+ arch = any
+ license = AGPL3
+ depends = seiscomp
+ source = https://www.seiscomp.de/downloader/seiscomp-maps.tar.gz
+ source = seiscomp-maps-tmpfiles.conf
+ sha256sums = e0488c4905260ab160b7ee2508ad5b70467665632b8f15428864cccb444e4cca
+ sha256sums = d322747672e4261c5aad058391b5c9d3e6dde34c05133edb9a9ef5c67aead1de
+
+pkgname = seiscomp-maps
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bca4af447a79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+pkgname=seiscomp-maps
+pkgver=4.8.2
+pkgrel=1
+pkgdesc="SeisComp map files."
+arch=('any')
+url="https://www.seiscomp.de"
+license=('AGPL3')
+depends=("${pkgname%-maps}")
+install=${pkgname}.install
+source=("${url}/downloader/${pkgname}.tar.gz"
+ "${pkgname}-tmpfiles.conf")
+sha256sums=('e0488c4905260ab160b7ee2508ad5b70467665632b8f15428864cccb444e4cca'
+ 'd322747672e4261c5aad058391b5c9d3e6dde34c05133edb9a9ef5c67aead1de')
+
+package() {
+ install -d "${pkgdir}/opt"
+ cp -r "${pkgname%-maps}" "${pkgdir}/opt/"
+ install -D -m 644 "${pkgname}-tmpfiles.conf" "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
+ chmod -R g+w "${pkgdir}/opt/${pkgname%-maps}/share/maps"
+}
+# vim:set ts=4 sw=4 et:
diff --git a/seiscomp-maps-tmpfiles.conf b/seiscomp-maps-tmpfiles.conf
new file mode 100644
index 000000000000..a26fe5ada904
--- /dev/null
+++ b/seiscomp-maps-tmpfiles.conf
@@ -0,0 +1,2 @@
+#Type Path Mode User Group Age Argument
+Z /opt/seiscomp/share/maps - seiscomp seiscomp - -
diff --git a/seiscomp-maps.install b/seiscomp-maps.install
new file mode 100644
index 000000000000..64dbbc417caa
--- /dev/null
+++ b/seiscomp-maps.install
@@ -0,0 +1,9 @@
+post_install() {
+ setfacl -d -m g::rwX opt/seiscomp
+ chmod g+s opt/seiscomp
+}
+
+post_upgrade() {
+ setfacl -d -m g::rwX opt/seiscomp
+ chmod g+s opt/seiscomp
+}