summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2018-04-24 23:34:31 +0430
committerMohammadreza Abdollahzadeh2018-04-24 23:34:31 +0430
commit84c3ea6f46ba59c379055feb2ae8cfcbaa140c83 (patch)
tree316a3305d54ef80f4dcf196aea5d5d4a7c9a43ce
downloadaur-84c3ea6f46ba59c379055feb2ae8cfcbaa140c83.tar.gz
Initial import
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD45
-rw-r--r--seiscomp3.sh3
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..539da7ce6166
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+# Generated by mksrcinfo v8
+# Tue Apr 24 19:03:50 UTC 2018
+pkgbase = seiscomp3
+ pkgdesc = A seismological software for data acquisition, processing, distribution and interactive analysis.
+ pkgver = 2017.334.05
+ pkgrel = 1
+ url = https://www.seiscomp3.org/
+ arch = x86_64
+ license = custom
+ makedepends = boost
+ makedepends = cmake
+ makedepends = libmariadbclient
+ makedepends = postgresql-libs
+ makedepends = python2-sphinx
+ depends = boost-libs
+ depends = libxml2
+ depends = mariadb
+ depends = ncurses
+ depends = openssl
+ depends = python2
+ depends = python2-m2crypto
+ depends = qt4
+ optdepends = postgresql: for using PostgreSQL database
+ source = seiscomp3-2017.334.05.tar.gz::https://github.com/SeisComP3/seiscomp3/archive/release/jakarta/2017.334.05.tar.gz
+ source = seiscomp3.sh
+ sha256sums = bee67847d2247c4ae2354c473acf81a184d5a61800d15ad00e24c69e38a40d76
+ sha256sums = 06157296f7cbc1fda7c09254b91143fc0463fe238133ebbff6437165e3000761
+
+pkgname = seiscomp3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3a739bcd416
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+pkgname=seiscomp3
+_screlease=jakarta
+pkgver=2017.334.05
+pkgrel=1
+pkgdesc="A seismological software for data acquisition, processing, distribution and interactive analysis."
+arch=('x86_64')
+url="https://www.seiscomp3.org/"
+license=('custom')
+depends=('boost-libs' 'libxml2' 'mariadb' 'ncurses' 'openssl' 'python2' 'python2-m2crypto' 'qt4')
+makedepends=('boost' 'cmake' 'libmariadbclient' 'postgresql-libs' 'python2-sphinx')
+optdepends=('postgresql: for using PostgreSQL database')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/SeisComP3/${pkgname}/archive/release/${_screlease}/${pkgver}.tar.gz"
+ "seiscomp3.sh")
+sha256sums=('bee67847d2247c4ae2354c473acf81a184d5a61800d15ad00e24c69e38a40d76'
+ '06157296f7cbc1fda7c09254b91143fc0463fe238133ebbff6437165e3000761')
+
+prepare() {
+ cd "${pkgname}-release-${_screlease}-${pkgver}"
+ sed -i "s/python/python2/g" ./doc/CMakeLists.txt
+ sed -i "s/sphinx-build/sphinx-build2/g" ./doc/build-doc.py
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd "${pkgname}-release-${_screlease}-${pkgver}/build"
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX='/opt/seiscomp3' \
+ -DPYTHON_EXECUTABLE='/usr/bin/python2' \
+ -DSC_DOC_GENERATE='ON'
+ make
+}
+
+package() {
+ cd "${pkgname}-release-${_screlease}-${pkgver}/build"
+ make DESTDIR="${pkgdir}/" install
+ install -Dm644 "${srcdir}/seiscomp3.sh" "${pkgdir}/etc/profile.d/seiscomp3.sh"
+ install -Dm644 "${srcdir}/${pkgname}-release-${_screlease}-${pkgver}/COPYING" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENCE"
+ find "${pkgdir}/opt/seiscomp3" -type f -exec sed -i "s/env python/env python2/g" '{}' \;
+}
+# vim:set ts=2 sw=2 et:
diff --git a/seiscomp3.sh b/seiscomp3.sh
new file mode 100644
index 000000000000..9bc0abd9e0f8
--- /dev/null
+++ b/seiscomp3.sh
@@ -0,0 +1,3 @@
+export PATH=${PATH}:/opt/seiscomp3/bin
+export LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:/opt/seiscomp3/lib
+export MANPATH=${MANPATH}:/opt/seiscomp3/share/man