summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2018-06-29 18:28:40 +0430
committerMohammadreza Abdollahzadeh2018-06-29 18:28:40 +0430
commit9c9aca639162c556e460736dd6572c10a38c5249 (patch)
treea22f93c4d4deae408393abba8b1218c79c660631
parent84c3ea6f46ba59c379055feb2ae8cfcbaa140c83 (diff)
downloadaur-9c9aca639162c556e460736dd6572c10a38c5249.tar.gz
fix rpc errors
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 539da7ce6166..18657a091399 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Apr 24 19:03:50 UTC 2018
+# Fri Jun 29 13:58:11 UTC 2018
pkgbase = seiscomp3
pkgdesc = A seismological software for data acquisition, processing, distribution and interactive analysis.
pkgver = 2017.334.05
- pkgrel = 1
+ pkgrel = 2
url = https://www.seiscomp3.org/
arch = x86_64
license = custom
@@ -13,6 +13,7 @@ pkgbase = seiscomp3
makedepends = postgresql-libs
makedepends = python2-sphinx
depends = boost-libs
+ depends = libtirpc
depends = libxml2
depends = mariadb
depends = ncurses
diff --git a/PKGBUILD b/PKGBUILD
index d3a739bcd416..e17346210b47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+
pkgname=seiscomp3
_screlease=jakarta
pkgver=2017.334.05
-pkgrel=1
+pkgrel=2
pkgdesc="A seismological software for data acquisition, processing, distribution and interactive analysis."
arch=('x86_64')
url="https://www.seiscomp3.org/"
license=('custom')
-depends=('boost-libs' 'libxml2' 'mariadb' 'ncurses' 'openssl' 'python2' 'python2-m2crypto' 'qt4')
+depends=('boost-libs' 'libtirpc' 'libxml2' 'mariadb' 'ncurses' 'openssl' 'python2' 'python2-m2crypto' 'qt4')
makedepends=('boost' 'cmake' 'libmariadbclient' 'postgresql-libs' 'python2-sphinx')
optdepends=('postgresql: for using PostgreSQL database')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/SeisComP3/${pkgname}/archive/release/${_screlease}/${pkgver}.tar.gz"
@@ -29,6 +30,9 @@ build() {
cd "${pkgname}-release-${_screlease}-${pkgver}/build"
cmake .. \
-DCMAKE_INSTALL_PREFIX='/opt/seiscomp3' \
+ -DCMAKE_CXX_FLAGS='-I/usr/include/tirpc' \
+ -DCMAKE_SHARED_LINKER_FLAGS='-ltirpc' \
+ -DCMAKE_EXE_LINKER_FLAGS='-ltirpc -lpthread' \
-DPYTHON_EXECUTABLE='/usr/bin/python2' \
-DSC_DOC_GENERATE='ON'
make