summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLatif Sulistyo2022-10-13 11:30:09 +0700
committerLatif Sulistyo2022-10-13 11:30:09 +0700
commitf8a3f70ad2694cfcf21f8a1faf9548d847baa985 (patch)
tree46c24f15675901eb7b866cc44dfd7ab7b3fd1ddc
downloadaur-f8a3f70ad2694cfcf21f8a1faf9548d847baa985.tar.gz
feat: initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..507a477fdc34
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = selectdefaultapplication-fork-git
+ pkgdesc = A very simple application that lets you define default applications on Linux in a sane way
+ pkgver = r72.4e8501d
+ pkgrel = 1
+ url = https://github.com/magnus-ISU/selectdefaultapplication
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = qt5-base
+ depends = hicolor-icon-theme
+ provides = selectdefaultapplication
+ conflicts = selectdefaultapplication
+ conflicts = selectdefaultapplication-git
+ source = git+https://github.com/magnus-ISU/selectdefaultapplication.git
+ md5sums = SKIP
+
+pkgname = selectdefaultapplication-fork-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7482854f5de3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Latif Sulistyo <latipun@aur.archlinux.org>
+
+# shellcheck disable=2034,2154
+# shellcheck shell=bash
+
+pkgname=selectdefaultapplication-fork-git
+pkgver=r72.4e8501d
+pkgrel=1
+pkgdesc='A very simple application that lets you define default applications on Linux in a sane way'
+arch=('i686' 'x86_64')
+url='https://github.com/magnus-ISU/selectdefaultapplication'
+license=('GPL')
+provides=("selectdefaultapplication")
+conflicts=("selectdefaultapplication" "selectdefaultapplication-git")
+depends=('qt5-base' 'hicolor-icon-theme')
+makedepends=('git')
+source=("git+$url.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd selectdefaultapplication || exit 1
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd selectdefaultapplication || exit 1
+ qmake
+ make
+}
+
+package() {
+ cd selectdefaultapplication || exit 1
+ install -dm755 "${pkgdir}/usr/bin/"
+ install -m755 selectdefaultapplication "${pkgdir}/usr/bin/"
+
+ install -dm755 "${pkgdir}/usr/share/applications/"
+ install -m644 selectdefaultapplication.desktop "${pkgdir}/usr/share/applications/"
+ install -dm755 "${pkgdir}/usr/share/icons/hicolor/48x48/apps/"
+ install -m644 selectdefaultapplication.png "${pkgdir}/usr/share/icons/hicolor/48x48/apps/"
+}