summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxim Andersson2016-01-09 04:04:03 +0100
committerMaxim Andersson2016-01-09 04:04:03 +0100
commit826c60b0a65a864bb2143d0b67c1578f851c676a (patch)
tree071f20dab11f6906682544c1adc6d04931c9fd31
parent237a8edbf077d519d2adea72fd025709ff1aa56f (diff)
downloadaur-826c60b0a65a864bb2143d0b67c1578f851c676a.tar.gz
Fix bug with update on php7
https://github.com/SSilence/selfoss/issues/731
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33a2ce2c16dc..67b50efb3342 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sat Jan 9 03:03:11 UTC 2016
pkgbase = selfoss
pkgdesc = The new multipurpose rss reader, live stream, mashup, aggregation web application
pkgver = 2.14
- pkgrel = 1
+ pkgrel = 2
url = http://selfoss.aditu.de/
install = selfoss.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index d5381ab16ea3..d22bba319caa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=selfoss
pkgver=2.14
-pkgrel=1
+pkgrel=2
pkgdesc="The new multipurpose rss reader, live stream, mashup, aggregation web application"
arch=('any')
url="http://selfoss.aditu.de/"
@@ -24,6 +24,14 @@ install=${pkgname}.install
source=("https://github.com/SSilence/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.zip")
sha256sums=('23ddf9de2d5192133701576d66e45e1509b468160236e600b80d86737c1052e9')
+prepare() {
+ cd "${srcdir}/libs"
+
+ # Fix bug with update on php7
+ sed -i 's/function floIconImage/function __construct/' floIcon.php
+ sed -i 's/function floIcon/function __construct/' floIcon.php
+}
+
package() {
rm -rf "${srcdir}"/{README.md,${pkgname}-${pkgver}.zip}