summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2016-07-10 05:26:46 -0400
committerJames An2016-07-10 05:26:46 -0400
commit3869f5615712fd914295a14cd42e94d4b951e6a4 (patch)
treeb346a050b103d4b5972039b75fed74dd0027e1f6
parentefa194f69fb2944f76832f60a35bc9e9eb05d617 (diff)
downloadaur-3869f5615712fd914295a14cd42e94d4b951e6a4.tar.gz
Simplified pathing with equivalent replacements.
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0412a6e640f8..7419e17a7169 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,21 +31,19 @@ md5sums=('SKIP'
'SKIP')
pkgver() {
- cd $srcdir/_pkgname
+ cd $_pkgname
git describe --long | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
}
prepare() {
- cd $srcdir/$_pkgname
+ cd $_pkgname
sed -i 's/env python/env python2/g' $_pkgname/__init__.py
sed -i 's:var/lib:usr/share:g' Makefile
}
package() {
- cd $srcdir/$_pkgname
- install -d $pkgdir/usr/{bin,share/selfspy}
- install -d $pkgdir/usr/lib/systemd/system
+ cd $_pkgname
python2 setup.py install --root="$pkgdir/" --optimize=1
- install -Dm644 ../$_pkgname@.service $pkgdir/usr/lib/systemd/system/
+ install -Dm644 ../$_pkgname@.service $pkgdir/usr/lib/systemd/system/$_pkgname@.service
install -Dm644 ../$_pkgname.conf $pkgdir/usr/share/$_pkgname/$_pkgname.conf.example
}