summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2017-08-11 13:56:40 +0200
committerNicolas Iooss2017-08-11 13:56:40 +0200
commit2ca99de8e0e3a4549a2adb023e1853ed5e204c06 (patch)
treef098b3d47cda32ca6f74ecc5da82f1dcd724d971
downloadaur-2ca99de8e0e3a4549a2adb023e1853ed5e204c06.tar.gz
Create selinux-dbus-config package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..763779231a3b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = selinux-dbus-config
+ pkgdesc = SELinux GUI tools
+ pkgver = 2.7
+ pkgrel = 1
+ url = https://github.com/SELinuxProject/selinux/wiki
+ arch = any
+ groups = selinux
+ license = GPL2
+ depends = python
+ depends = selinux-python
+ conflicts = policycoreutils<2.7
+ source = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20170804/selinux-dbus-2.7.tar.gz
+ sha256sums = a7f3dbe68c0d02cd1cbe6aac06e87c2957668cb88083389654fabacb79641ae4
+
+pkgname = selinux-dbus-config
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b7b27a180d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
+
+pkgname=selinux-dbus-config
+_pkgname=selinux-dbus
+pkgver=2.7
+pkgrel=1
+pkgdesc="SELinux GUI tools"
+groups=('selinux')
+arch=('any')
+url='https://github.com/SELinuxProject/selinux/wiki'
+license=('GPL2')
+depends=('python' 'selinux-python')
+conflicts=('policycoreutils<2.7')
+source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20170804/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('a7f3dbe68c0d02cd1cbe6aac06e87c2957668cb88083389654fabacb79641ae4')
+
+=build() {
+ cd "${_pkgname}-${pkgver}"
+ make=
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}