summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2018-10-06 15:20:53 +0200
committerNicolas Iooss2018-10-06 15:20:53 +0200
commit26591cccaef49bbb5cac471ac73a221b07603f02 (patch)
tree66cfdf1fa2c16873859f8b8e2a49f6f5fc039b9a
parent6c6ca397f99b09d425d1fa64b1bfe63d010defcc (diff)
downloadaur-26591cccaef49bbb5cac471ac73a221b07603f02.tar.gz
selinux-python 2.8-2 update: audit Python bindings were split into python-audit
While at it, fix an inconsistency between makedepends and depends arrays.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 99d0cb9f970b..c1da9932399a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = selinux-python
pkgdesc = SELinux python tools and libraries
pkgver = 2.8
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/SELinuxProject/selinux/wiki
arch = i686
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = selinux-python
makedepends = python-ipy
makedepends = libsemanage>=2.8
makedepends = setools>=4.0.0
- provides = sepolgen=2.8-1
+ provides = sepolgen=2.8-2
conflicts = sepolgen<2.7
conflicts = policycoreutils<2.7
source = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20180524/selinux-python-2.8.tar.gz
@@ -20,12 +20,14 @@ pkgbase = selinux-python
pkgname = selinux-python
depends = python
+ depends = python-audit
depends = python-ipy
- depends = libsemanage>=2.7
+ depends = libsemanage>=2.8
depends = setools>=4.0.0
pkgname = selinux-python2
depends = python2
- depends = libsemanage>=2.7
+ depends = python2-audit
+ depends = libsemanage>=2.8
depends = setools>=4.0.0
diff --git a/PKGBUILD b/PKGBUILD
index cb7da60123b4..6c5db5661963 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgbase=selinux-python
pkgname=(selinux-python selinux-python2)
pkgver=2.8
-pkgrel=1
+pkgrel=2
pkgdesc="SELinux python tools and libraries"
groups=('selinux')
arch=('i686' 'x86_64')
@@ -25,7 +25,7 @@ build() {
}
package_selinux-python() {
- depends=('python' 'python-ipy' 'libsemanage>=2.7' 'setools>=4.0.0')
+ depends=('python' 'python-audit' 'python-ipy' 'libsemanage>=2.8' 'setools>=4.0.0')
cd "${pkgbase}-${pkgver}"
make PYTHON=/usr/bin/python3 DESTDIR="${pkgdir}" SBINDIR=/usr/bin install
@@ -33,7 +33,7 @@ package_selinux-python() {
}
package_selinux-python2() {
- depends=('python2' 'libsemanage>=2.7' 'setools>=4.0.0')
+ depends=('python2' 'python2-audit' 'libsemanage>=2.8' 'setools>=4.0.0')
cd "${pkgbase}-${pkgver}"