summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2023-03-15 19:39:48 +0100
committerNicolas Iooss2023-03-15 19:39:48 +0100
commit54a71b8247b08cc7e25a846396fa5cbd0ad5efce (patch)
tree253eb66b3b39157cccd703dd2803e2bb61cb4f02
parentcdeb72d71d79c510684f7b49a4e89afd7febeb0b (diff)
downloadaur-54a71b8247b08cc7e25a846396fa5cbd0ad5efce.tar.gz
selinux-python 3.5-1 update
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD12
2 files changed, 17 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8eae14af1cde..678227ae0281 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = selinux-python
pkgdesc = SELinux python tools and libraries
- pkgver = 3.4
+ pkgver = 3.5
pkgrel = 1
url = https://github.com/SELinuxProject/selinux/wiki
arch = i686
@@ -8,18 +8,21 @@ pkgbase = selinux-python
arch = aarch64
groups = selinux
license = GPL2
+ makedepends = python-pip
+ makedepends = python-setuptools
depends = python
depends = python-audit
depends = python-ipy
- depends = libsemanage>=3.4
+ depends = libsemanage>=3.5
depends = setools>=4.4.0
- provides = sepolgen=3.4-1
+ provides = sepolgen=3.5-1
conflicts = sepolgen<2.7
conflicts = policycoreutils<2.7
- source = https://github.com/SELinuxProject/selinux/releases/download/3.4/selinux-python-3.4.tar.gz
- source = https://github.com/SELinuxProject/selinux/releases/download/3.4/selinux-python-3.4.tar.gz.asc
+ source = https://github.com/SELinuxProject/selinux/releases/download/3.5/selinux-python-3.5.tar.gz
+ source = https://github.com/SELinuxProject/selinux/releases/download/3.5/selinux-python-3.5.tar.gz.asc
+ validpgpkeys = 63191CE94183098689CAB8DB7EF137EC935B0EAF
validpgpkeys = E853C1848B0185CF42864DF363A8AD4B982C4373
- sha256sums = 1731065a58293b8a598c0f8b182fdd1a278959b1288747fcb17af392496bac32
+ sha256sums = 8245bb4dae59333461f19ca0c79a829081f07972fa5e3ad4c2b2b917dd71d96b
sha256sums = SKIP
pkgname = selinux-python
diff --git a/PKGBUILD b/PKGBUILD
index 6809a00a1e3c..1ff9746df77f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,23 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgname=selinux-python
-pkgver=3.4
+pkgver=3.5
pkgrel=1
pkgdesc="SELinux python tools and libraries"
groups=('selinux')
arch=('i686' 'x86_64' 'aarch64')
url='https://github.com/SELinuxProject/selinux/wiki'
license=('GPL2')
-depends=('python' 'python-audit' 'python-ipy' 'libsemanage>=3.4' 'setools>=4.4.0')
+makedepends=('python-pip' 'python-setuptools')
+depends=('python' 'python-audit' 'python-ipy' 'libsemanage>=3.5' 'setools>=4.4.0')
conflicts=('sepolgen<2.7' 'policycoreutils<2.7')
provides=("sepolgen=${pkgver}-${pkgrel}")
-validpgpkeys=('E853C1848B0185CF42864DF363A8AD4B982C4373') # Petr Lautrbach <plautrba@redhat.com>
+validpgpkeys=(
+ '63191CE94183098689CAB8DB7EF137EC935B0EAF' # Jason Zaman <perfinion@gentoo.org>
+ 'E853C1848B0185CF42864DF363A8AD4B982C4373' # Petr Lautrbach <plautrba@redhat.com>
+)
source=("https://github.com/SELinuxProject/selinux/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz"{,.asc})
-sha256sums=('1731065a58293b8a598c0f8b182fdd1a278959b1288747fcb17af392496bac32'
+sha256sums=('8245bb4dae59333461f19ca0c79a829081f07972fa5e3ad4c2b2b917dd71d96b'
'SKIP')
build() {