summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2018-05-26 18:42:00 +0200
committerNicolas Iooss2018-05-26 18:42:00 +0200
commit6c6ca397f99b09d425d1fa64b1bfe63d010defcc (patch)
treef5edbdeb9b650adf4598687b7a396febf1fce8ab
parent271ed425743b4b23e0c89d5070b61ecacd1fd5d1 (diff)
downloadaur-6c6ca397f99b09d425d1fa64b1bfe63d010defcc.tar.gz
selinux-python 2.8-1 update
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD30
2 files changed, 20 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb257d512372..99d0cb9f970b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = selinux-python
pkgdesc = SELinux python tools and libraries
- pkgver = 2.7
+ pkgver = 2.8
pkgrel = 1
url = https://github.com/SELinuxProject/selinux/wiki
arch = i686
@@ -10,13 +10,13 @@ pkgbase = selinux-python
makedepends = python2
makedepends = python
makedepends = python-ipy
- makedepends = libsemanage>=2.7
+ makedepends = libsemanage>=2.8
makedepends = setools>=4.0.0
- provides = sepolgen=2.7-1
+ provides = sepolgen=2.8-1
conflicts = sepolgen<2.7
conflicts = policycoreutils<2.7
- source = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20170804/selinux-python-2.7.tar.gz
- sha256sums = 4217cb965ecda96c91e15ffcc2e7ddd13ecc2bf5631100f3cd072a7616f140ed
+ source = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20180524/selinux-python-2.8.tar.gz
+ sha256sums = e69f5e24820cb247a3d881a9c90efba1e64d76af863c82fb81bc3b87ed71e238
pkgname = selinux-python
depends = python
diff --git a/PKGBUILD b/PKGBUILD
index 5ea6b8cf182d..cb7da60123b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,22 @@
# Maintainer: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
+#
+# This PKGBUILD is maintained on https://github.com/archlinuxhardened/selinux.
+# If you want to help keep it up to date, please open a Pull Request there.
pkgbase=selinux-python
pkgname=(selinux-python selinux-python2)
-pkgver=2.7
+pkgver=2.8
pkgrel=1
pkgdesc="SELinux python tools and libraries"
groups=('selinux')
arch=('i686' 'x86_64')
url='https://github.com/SELinuxProject/selinux/wiki'
license=('GPL2')
-makedepends=('python2' 'python' 'python-ipy' 'libsemanage>=2.7' 'setools>=4.0.0')
+makedepends=('python2' 'python' 'python-ipy' 'libsemanage>=2.8' 'setools>=4.0.0')
conflicts=('sepolgen<2.7' 'policycoreutils<2.7')
provides=("sepolgen=${pkgver}-${pkgrel}")
-source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20170804/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('4217cb965ecda96c91e15ffcc2e7ddd13ecc2bf5631100f3cd072a7616f140ed')
+source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20180524/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('e69f5e24820cb247a3d881a9c90efba1e64d76af863c82fb81bc3b87ed71e238')
build() {
cd "${pkgbase}-${pkgver}"
@@ -25,10 +28,7 @@ package_selinux-python() {
depends=('python' 'python-ipy' 'libsemanage>=2.7' 'setools>=4.0.0')
cd "${pkgbase}-${pkgver}"
- make PYTHON=/usr/bin/python3 DESTDIR="${pkgdir}" \
- LIBSEPOLA=/usr/lib/libsepol.a \
- SBINDIR="${pkgdir}/usr/bin" \
- install
+ make PYTHON=/usr/bin/python3 DESTDIR="${pkgdir}" SBINDIR=/usr/bin install
/usr/bin/python3 -m compileall "${pkgdir}/$(/usr/bin/python3 -c 'import site; print(site.getsitepackages()[0])')"
}
@@ -36,16 +36,16 @@ package_selinux-python2() {
depends=('python2' 'libsemanage>=2.7' 'setools>=4.0.0')
cd "${pkgbase}-${pkgver}"
+
# Guide the files which would conflict with selinux-python package into a
# special directory, which would then be removed
make PYTHON=/usr/bin/python2 DESTDIR="${pkgdir}" \
- BASHCOMPLETIONDIR="${pkgdir}/removed" \
- BINDIR="${pkgdir}/removed" \
- LIBDIR="${pkgdir}/removed" \
- LIBSEPOLA=/usr/lib/libsepol.a \
- MANDIR="${pkgdir}/removed" \
- SBINDIR="${pkgdir}/removed" \
- SHAREDIR="${pkgdir}/removed" \
+ BASHCOMPLETIONDIR=/removed \
+ BINDIR=/removed \
+ LIBDIR=/removed \
+ MANDIR=/removed \
+ SBINDIR=/removed \
+ SHAREDIR=/removed \
install
rm -r "${pkgdir}/removed"
/usr/bin/python2 -m compileall "${pkgdir}/$(/usr/bin/python2 -c 'import site; print(site.getsitepackages()[0])')"