summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2020-07-19 11:32:43 +0200
committerNicolas Iooss2020-07-19 11:32:43 +0200
commitd1d7f3a29b335be386683ba8c0d6f87c7d85ebc7 (patch)
tree6a6657828d2d0afedae738a06cffd821c374fb4a
parent27fcf258bd0377f47574090dbfc33dade68d85eb (diff)
downloadaur-d1d7f3a29b335be386683ba8c0d6f87c7d85ebc7.tar.gz
selinux-python 3.1-1 update
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f9bbf43b8ca..d69b02f49cd5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = selinux-python
pkgdesc = SELinux python tools and libraries
- pkgver = 3.0
+ pkgver = 3.1
pkgrel = 1
url = https://github.com/SELinuxProject/selinux/wiki
arch = i686
@@ -10,13 +10,13 @@ pkgbase = selinux-python
depends = python
depends = python-audit
depends = python-ipy
- depends = libsemanage>=2.8
+ depends = libsemanage>=3.1
depends = setools>=4.0.0
- provides = sepolgen=3.0-1
+ provides = sepolgen=3.1-1
conflicts = sepolgen<2.7
conflicts = policycoreutils<2.7
- source = https://github.com/SELinuxProject/selinux/releases/download/20191204/selinux-python-3.0.tar.gz
- sha256sums = 43c08fa881ccc64251d396b1ac6c56b354bf98421b4ec937d54a8db190135494
+ source = https://github.com/SELinuxProject/selinux/releases/download/20200710/selinux-python-3.1.tar.gz
+ sha256sums = f4d0a1a030bc291a6af498b26e0676b745075dd289a8ba16cdec86c3ea8f2f02
pkgname = selinux-python
diff --git a/PKGBUILD b/PKGBUILD
index 747a3e9173a3..06046ace6b16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,18 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgname=selinux-python
-pkgver=3.0
+pkgver=3.1
pkgrel=1
pkgdesc="SELinux python tools and libraries"
groups=('selinux')
arch=('i686' 'x86_64')
url='https://github.com/SELinuxProject/selinux/wiki'
license=('GPL2')
-depends=('python' 'python-audit' 'python-ipy' 'libsemanage>=2.8' 'setools>=4.0.0')
+depends=('python' 'python-audit' 'python-ipy' 'libsemanage>=3.1' 'setools>=4.0.0')
conflicts=('sepolgen<2.7' 'policycoreutils<2.7')
provides=("sepolgen=${pkgver}-${pkgrel}")
-source=("https://github.com/SELinuxProject/selinux/releases/download/20191204/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('43c08fa881ccc64251d396b1ac6c56b354bf98421b4ec937d54a8db190135494')
+source=("https://github.com/SELinuxProject/selinux/releases/download/20200710/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('f4d0a1a030bc291a6af498b26e0676b745075dd289a8ba16cdec86c3ea8f2f02')
build() {
cd "${pkgbase}-${pkgver}"
@@ -26,5 +26,4 @@ package() {
cd "${pkgbase}-${pkgver}"
make PYTHON=/usr/bin/python3 DESTDIR="${pkgdir}" SBINDIR=/usr/bin install
/usr/bin/python3 -m compileall "${pkgdir}/$(/usr/bin/python3 -c 'import site; print(site.getsitepackages()[0])')"
- /usr/bin/python3 -O -m compileall "${pkgdir}/$(/usr/bin/python3 -c 'import site; print(site.getsitepackages()[0])')"
}