summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2020-02-11 18:24:06 +0100
committerPellegrino Prevete2020-02-11 18:24:06 +0100
commitb4dd1670be6b0c793e5a417a932a2e12d9d76a7a (patch)
treed4c4591ae2cacfc2b689414360330f3c089ec0b0
downloadaur-b4dd1670be6b0c793e5a417a932a2e12d9d76a7a.tar.gz
initial release
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD30
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..12d955232808
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = selinux-python2
+ pkgdesc = SELinux python 2.X tools and libraries
+ pkgver = 3.0
+ pkgrel = 1
+ url = https://github.com/SELinuxProject/selinux/wiki
+ arch = i686
+ arch = x86_64
+ groups = selinux
+ license = GPL2
+ depends = python2
+ depends = python2-audit
+ depends = python2-ipy
+ depends = libsemanage>=2.8
+ depends = setools>=4.0.0
+ provides = sepolgen=3.0-1
+ conflicts = sepolgen<2.7
+ conflicts = policycoreutils<2.7
+ source = https://github.com/SELinuxProject/selinux/releases/download/20191204/selinux-python-3.0.tar.gz
+ sha256sums = 43c08fa881ccc64251d396b1ac6c56b354bf98421b4ec937d54a8db190135494
+
+pkgname = selinux-python2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c384d1778641
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Mantainer: Pellegrino Prevete <cGVsbGVncmlub3ByZXZldGVAZ21haWwuY29tCg== | base -d>
+#
+# This PKGBUILD is maintained on https://github.com/archlinuxhardened/selinux.
+# If you want to help keep it up to date, please open a Pull Request there.
+
+pkgname=selinux-python2
+pkgver=3.0
+pkgrel=1
+pkgdesc="SELinux python 2.X tools and libraries"
+groups=('selinux')
+arch=('i686' 'x86_64')
+url='https://github.com/SELinuxProject/selinux/wiki'
+license=('GPL2')
+depends=('python2' 'python2-audit' 'python2-ipy' 'libsemanage>=2.8' 'setools>=4.0.0')
+conflicts=('sepolgen<2.7' 'policycoreutils<2.7')
+provides=("sepolgen=${pkgver}-${pkgrel}")
+source=("https://github.com/SELinuxProject/selinux/releases/download/20191204/selinux-python-${pkgver}.tar.gz")
+sha256sums=('43c08fa881ccc64251d396b1ac6c56b354bf98421b4ec937d54a8db190135494')
+
+build() {
+ cd "selinux-python-${pkgver}"
+ make PYTHON=/usr/bin/python2
+}
+
+package() {
+ cd "selinux-python-${pkgver}"
+ make PYTHON=/usr/bin/python2 DESTDIR="${pkgdir}" SBINDIR=/usr/bin install
+ /usr/bin/python2 -m compileall "${pkgdir}/$(/usr/bin/python2 -c 'import site; print(site.getsitepackages()[0])')"
+ /usr/bin/python2 -O -m compileall "${pkgdir}/$(/usr/bin/python2 -c 'import site; print(site.getsitepackages()[0])')"
+}