summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2017-12-15 20:12:52 +0100
committerNicolas Iooss2017-12-15 20:14:59 +0100
commit91fbde44c600394071525596b10ca7a2e80b7c44 (patch)
treeb4cd947eec1c861cd32405ce02c159bcfdc6c3f6
parent43d289f93ede80b9c5414fd2d2564ecee422233c (diff)
downloadaur-91fbde44c600394071525596b10ca7a2e80b7c44.tar.gz
selinux-refpolicy-git RELEASE_2_20170805.r150.g94f1a1b3f30f-1 update
The reference policy added support of the map permission, introduced in recent kernels. Update the package release to signal users to update. While at it, sync PKGBUILD and install scripts with selinux-refpolicy-arch package.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
-rw-r--r--selinux-refpolicy-git.install6
3 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 092b74ff9aa9..c54a8619fb15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = selinux-refpolicy-git
pkgdesc = Modular SELinux reference policy including headers and docs
- pkgver = RELEASE_2_20170805.r8.g0ba1970b7cd4
+ pkgver = RELEASE_2_20170805.r150.g94f1a1b3f30f
pkgrel = 1
url = https://github.com/TresysTechnology/refpolicy/wiki
install = selinux-refpolicy-git.install
diff --git a/PKGBUILD b/PKGBUILD
index 6177991e1833..74e3ebee5b17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=selinux-refpolicy-git
_policyname=refpolicy-git
-pkgver=RELEASE_2_20170805.r8.g0ba1970b7cd4
+pkgver=RELEASE_2_20170805.r150.g94f1a1b3f30f
pkgrel=1
pkgdesc="Modular SELinux reference policy including headers and docs"
arch=('any')
@@ -56,6 +56,10 @@ package() {
DESTDIR="${pkgdir}" NAME="${_policyname}" DISTRO=arch SYSTEMD=y UBAC=n \
PKGNAME="${_policyname}"
+ # Create /var/lib/selinux, which is necessary for loading policy,
+ # which is done via install script.
+ install -d -m0755 "${pkgdir}/var/lib/selinux"
+
# Install main SELinux config file defaulting to refpolicy
install -m644 -D "${srcdir}/config" "${pkgdir}/etc/selinux/config.${_policyname}"
}
diff --git a/selinux-refpolicy-git.install b/selinux-refpolicy-git.install
index 15aa418eb850..df982b098a60 100644
--- a/selinux-refpolicy-git.install
+++ b/selinux-refpolicy-git.install
@@ -1,12 +1,14 @@
post_install() {
- echo ">>> Building refpolicy-git policy store. Please wait ..."
- /usr/bin/semodule -s refpolicy-git -i /usr/share/selinux/refpolicy-git/*.pp
+ # Configure /etc/selinux/config
if [ -e /etc/selinux/config ]
then
echo ">>> In order to use this policy, set SELINUXTYPE=refpolicy-git in /etc/selinux/config."
else
/usr/bin/ln -v -s config.refpolicy-git /etc/selinux/config
fi
+
+ echo ">>> Building refpolicy-git policy store. Please wait..."
+ /usr/bin/semodule -s refpolicy-git -i /usr/share/selinux/refpolicy-git/*.pp
echo ">>> Relabeling the filesystem may be needed."
echo ">>> This can be done with: /usr/bin/restorecon -rF /"
}