summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-08-22 12:23:25 +0800
committerzxp198210052023-08-22 12:23:25 +0800
commitbe26d43d47b222c509a4bb2417529090b61d10b3 (patch)
tree5270d7681d65b345306aed085b439d54062c0864
downloadaur-be26d43d47b222c509a4bb2417529090b61d10b3.tar.gz
first release
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD30
-rw-r--r--selvania-launcher.sh8
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..137b9d1db138
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = selvania-launcher-bin
+ pkgdesc = Custom launcher for modded minecraft written in electron.js and Node.js
+ pkgver = 1.3.2
+ pkgrel = 1
+ url = http://luuxis.fr/
+ arch = x86_64
+ license = custom
+ makedepends = gendesk
+ depends = bash
+ depends = electron26
+ provides = selvania-launcher=1.3.2
+ conflicts = selvania-launcher
+ source = selvania-launcher-1.3.2.tar.gz::https://github.com/luuxis/Selvania-Launcher/releases/download/1.3.2/Selvania-Launcher-linux-x64.tar.gz
+ source = selvania-launcher.png::https://raw.githubusercontent.com/luuxis/Selvania-Launcher/master/src/assets/images/icon.png
+ source = LICENSE::https://raw.githubusercontent.com/luuxis/Selvania-Launcher/master/LICENSE.md
+ source = selvania-launcher.sh
+ sha256sums = 0074282d833aa7ecf02a5df57d36a5bf35edb3ec49bd7badf2ed24d8ec25c632
+ sha256sums = 8b6d0dde9d975f1f9fe7c8307066a6e0d06ba316ee1ef239359ead9d007316ab
+ sha256sums = 7c73b8f626696c0403394da3dae0d5ed33009cc2d674803d40bc4e2c7e67174b
+ sha256sums = 98674e99c34736bfdd74affe611c813b08f69674e2240cd894c3dfb567ea574f
+
+pkgname = selvania-launcher-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e25aa784368
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=selvania-launcher-bin
+_pkgname=Selvania-Launcher
+pkgver=1.3.2
+pkgrel=1
+pkgdesc="Custom launcher for modded minecraft written in electron.js and Node.js"
+arch=("x86_64")
+url="http://luuxis.fr/"
+_githuburl="https://github.com/luuxis/Selvania-Launcher"
+license=("custom")
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
+depends=('bash' 'electron26')
+makedepends=('gendesk')
+source=("${pkgname%-bin}-${pkgver}.tar.gz::${_githuburl}/releases/download/${pkgver}/${_pkgname}-linux-x64.tar.gz"
+ "${pkgname%-bin}.png::https://raw.githubusercontent.com/luuxis/Selvania-Launcher/master/src/assets/images/icon.png"
+ "LICENSE::https://raw.githubusercontent.com/luuxis/Selvania-Launcher/master/LICENSE.md"
+ "${pkgname%-bin}.sh")
+sha256sums=('0074282d833aa7ecf02a5df57d36a5bf35edb3ec49bd7badf2ed24d8ec25c632'
+ '8b6d0dde9d975f1f9fe7c8307066a6e0d06ba316ee1ef239359ead9d007316ab'
+ '7c73b8f626696c0403394da3dae0d5ed33009cc2d674803d40bc4e2c7e67174b'
+ '98674e99c34736bfdd74affe611c813b08f69674e2240cd894c3dfb567ea574f')
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/${_pkgname//-/ }-linux-x64/resources/app.asar" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.asar"
+ install -Dm644 "${srcdir}/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
+ install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ gendesk -f -n --categories "Game" --name "${_pkgname}" --exec "${pkgname%-bin}"
+ install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+} \ No newline at end of file
diff --git a/selvania-launcher.sh b/selvania-launcher.sh
new file mode 100644
index 000000000000..9bd8676b4d83
--- /dev/null
+++ b/selvania-launcher.sh
@@ -0,0 +1,8 @@
+#!/bin/bash
+_ELECTRON=/usr/bin/electron26
+_ASAR="/opt/selvania-launcher/selvania-launcher.asar"
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec ${_ELECTRON} ${_ASAR} "$@"
+else
+ exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
+fi \ No newline at end of file