summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoretaboon2018-10-26 22:08:32 +0200
committeretaboon2018-10-26 22:08:32 +0200
commit71dca882c644e1e2306d8d900a6feb603794c936 (patch)
tree66a5d86dc93d56652cdc481c8ddb3d0a2f30758a
parentb69af56ab4bc34dc9c6233dfdad7ad65a1ebb782 (diff)
downloadaur-71dca882c644e1e2306d8d900a6feb603794c936.tar.gz
Correcting dependencies
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
-rw-r--r--semantik.install38
3 files changed, 46 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75060a90ae8d..626f49d54049 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = semantik
pkgdesc = mindmapping-like tool for document generation (reports, thesis, etc)
pkgver = 1.0.6
- pkgrel = 1
+ pkgrel = 2
url = https://waf.io/semantik.html
+ install = semantik.install
arch = x86_64
license = GPL3
depends = qt5-webengine
@@ -12,6 +13,8 @@ pkgbase = semantik
depends = python
depends = shared-mime-info
depends = desktop-file-utils
+ depends = python-pygments
+ optdepends = minted: syntax highlighting support in documents generated by LaTeX
source = https://waf.io/semantik-1.0.6.tar.bz2
sha256sums = 2a36def6c63a5e03f66f5d416964f544e7d1e26a794798be492d2b4869657a4a
diff --git a/PKGBUILD b/PKGBUILD
index 06a4a03dea76..891364634c0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,15 @@
# Contributor: der_fenix <derfenix -_AT_- gmail -_DOT_- com>
pkgname=semantik
pkgver=1.0.6
-pkgrel=1
+pkgrel=2
pkgdesc="mindmapping-like tool for document generation (reports, thesis, etc)"
arch=('x86_64')
url="https://waf.io/semantik.html"
license=('GPL3')
depends=('qt5-webengine' 'qt5-svg' 'kdelibs4support' 'kio' 'python'
- 'shared-mime-info' 'desktop-file-utils')
+ 'shared-mime-info' 'desktop-file-utils' 'python-pygments')
+install=$pkgname.install
+optdepends=('minted: syntax highlighting support in documents generated by LaTeX')
source=("https://waf.io/${pkgname}-${pkgver}.tar.bz2")
sha256sums=('2a36def6c63a5e03f66f5d416964f544e7d1e26a794798be492d2b4869657a4a')
diff --git a/semantik.install b/semantik.install
new file mode 100644
index 000000000000..dca3771c2ee6
--- /dev/null
+++ b/semantik.install
@@ -0,0 +1,38 @@
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+note1() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+note2() {
+ printf "${blue}==> ${bold} $1${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+post_install() {
+ note1 "In order to have code syntax highlighting in documents generated by LaTeX,"
+ note2 "you will have to install minted. Then, to make it work, add this"
+ note2 "to your .bashrc :"
+ note2 "export DISABLING_SHELL_ESCAPE_FOR_SEMANTIK=1"
+ note1 "As this disables the shell escaping options for Pdflatex, a maliciously"
+ note2 "creafted document might run arbitrary commands on your computer."
+ note2 "Only build Semantik documents that you have created yourself !"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ note1 "You can now remove from your .bashrc this line :"
+ note2 "export DISABLING_SHELL_ESCAPE_FOR_SEMANTIK=1"
+ note2 "if you have installed minted alongside Semantik for code"
+ note2 "syntax highlighting in documents generated by LaTex."
+}