summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2018-06-05 00:40:15 +0200
committerNarrat2018-06-05 00:40:15 +0200
commitaf3563d4e2873709fbe2b8e5829cb39d5ccb6277 (patch)
tree692944568a78b9c0f41291834adf9ae6f5edc36d
parent7e6c3cceceff4c3a07a185484bb423912882c236 (diff)
downloadaur-af3563d4e2873709fbe2b8e5829cb39d5ccb6277.tar.gz
Update to 1.0.3
Changes: * Use waf which comes with the tarball * Change deps to the one mentioned in the repo * Remove non needed stuff * License is GPL3
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD28
-rw-r--r--install11
3 files changed, 26 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 72467e6d20d3..fb66e687fb0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
-# Generated by mksrcinfo v8
-# Thu Jun 9 06:41:17 UTC 2016
pkgbase = semantik
- pkgdesc = A mindmapping-like tool for document generation (reports, thesis, etc)
- pkgver = 0.9.4
- pkgrel = 3
- url = https://ita1024.github.io/semantik/
- install = install
+ pkgdesc = mindmapping-like tool for document generation (reports, thesis, etc)
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://waf.io/semantik.html
arch = i686
arch = x86_64
- license = GPL
- makedepends = waf
- depends = kdebase-runtime
- source = https://github.com/ita1024/semantik/archive/semantik-0.9.4.tar.gz
- source = install
- sha256sums = 479fb3e822e7c4bc887019071bdf9fb8e2fad951ae6b54e5c76fba8e738dc684
- sha256sums = a981f2afe77ec69545b3912a99ee6c560388d178cd39c9a21ae21e270024159b
+ license = GPL3
+ depends = qt5-webengine
+ depends = qt5-svg
+ depends = kdelibs4support
+ depends = kio
+ depends = python3
+ depends = shared-mime-info
+ depends = desktop-file-utils
+ source = https://github.com/ita1024/semantik/archive/semantik-1.0.3.tar.gz
+ sha256sums = 723a6850c3f003b44756ad1faa0cab48cf141c36956a2cb4a6da7ec749631458
pkgname = semantik
diff --git a/PKGBUILD b/PKGBUILD
index c593dbcc8306..fe89d4e86d6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,25 @@
-# Maintainer: der_FeniX <derfenix@gmail.com>
+# Contributor: der_FeniX <derfenix@gmail.com>
pkgname=semantik
-pkgver=0.9.4
-pkgrel=3
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="mindmapping-like tool for document generation (reports, thesis, etc)"
arch=('i686' 'x86_64')
-url="https://ita1024.github.io/semantik/"
-makedepends=('waf')
-license=('GPL')
-source=("https://github.com/ita1024/semantik/archive/${pkgname}-${pkgver}.tar.gz" 'install')
+url="https://waf.io/semantik.html"
+license=('GPL3')
+depends=('qt5-webengine' 'qt5-svg' 'kdelibs4support' 'kio' 'python3'
+ 'shared-mime-info' 'desktop-file-utils')
+source=("https://github.com/ita1024/semantik/archive/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('723a6850c3f003b44756ad1faa0cab48cf141c36956a2cb4a6da7ec749631458')
-pkgdesc="A mindmapping-like tool for document generation (reports, thesis, etc)"
-depends=('kdebase-runtime')
-install='install'
-
-sha256sums=('479fb3e822e7c4bc887019071bdf9fb8e2fad951ae6b54e5c76fba8e738dc684'
- 'a981f2afe77ec69545b3912a99ee6c560388d178cd39c9a21ae21e270024159b')
build() {
cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
- sed -i 's/0755/755/g' wscript
- PYTHON=python2 PYTHON_VERSION=2.7 waf configure build
+ PYTHON=python3 PYTHON_VERSION=3.6 ./waf configure build --prefix=/usr
}
package() {
cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
- PYTHON=python2 PYTHON_VERSION=2.7 waf install --destdir="${pkgdir}"
+ PYTHON=python3 PYTHON_VERSION=3.6 DESTDIR="${pkgdir}" ./waf install
}
diff --git a/install b/install
deleted file mode 100644
index 980165cdefd5..000000000000
--- a/install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- update-desktop-database -q
- update-mime-database /usr/share/mime
-}
-
-post_remove() {
- update-desktop-database -q
- update-mime-database /usr/share/mime
-}
-
-