summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAloxaf2020-10-09 23:36:15 +0800
committerAloxaf2020-10-09 23:36:15 +0800
commit06f496910970d42a966942646a19a60b7f8a4d1b (patch)
tree2fa29ab26ab3cf8537a727fb1c554eae72aa199e
parentb77ab03da2583c060627354356ba9554fd9cc416 (diff)
downloadaur-06f496910970d42a966942646a19a60b7f8a4d1b.tar.gz
Update to 0.27.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 181afb02f038..bdd3b09290f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = semgrep-bin
pkgdesc = Fast and syntax-aware semantic code pattern search for many languages: like grep but for code
- pkgver = 0.25.0
+ pkgver = 0.27.0
pkgrel = 1
url = https://github.com/returntocorp/semgrep
arch = x86_64
@@ -18,10 +18,10 @@ pkgbase = semgrep-bin
depends = python-jsonschema
provides = semgrep
options = !strip
- source = https://github.com/returntocorp/semgrep/releases/download/v0.25.0/semgrep-v0.25.0-ubuntu-16.04.tgz
- source = https://files.pythonhosted.org/packages/source/s/semgrep/semgrep-0.25.0.tar.gz
- sha256sums = 976bad41ca1848cc51dbfd99d269793ebeffc246d722336bd4305cd85175e49e
- sha256sums = b4ce98f8cd5f5cc2c2a23c2cb1b998505712dc4e212cf60c68532fc4d9d09679
+ source = https://github.com/returntocorp/semgrep/releases/download/v0.27.0/semgrep-v0.27.0-ubuntu-16.04.tgz
+ source = https://files.pythonhosted.org/packages/source/s/semgrep/semgrep-0.27.0.tar.gz
+ sha256sums = 79dee3b382b634623c3f32a835c2257a131c97022a824c318aee487619030b2e
+ sha256sums = 3229b1bd653d2bb66dce15d01eebae17053cc40c2dac2997668e7468416faba3
pkgname = semgrep-bin
diff --git a/PKGBUILD b/PKGBUILD
index 425507397741..5095054a3f6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=semgrep-bin
_name=semgrep
-pkgver=0.25.0
+pkgver=0.27.0
pkgrel=1
pkgdesc="Fast and syntax-aware semantic code pattern search for many languages: like grep but for code"
arch=(x86_64)
@@ -16,8 +16,8 @@ source=(
"https://github.com/returntocorp/semgrep/releases/download/v${pkgver}/semgrep-v${pkgver}-ubuntu-16.04.tgz"
"https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
)
-sha256sums=('976bad41ca1848cc51dbfd99d269793ebeffc246d722336bd4305cd85175e49e'
- 'b4ce98f8cd5f5cc2c2a23c2cb1b998505712dc4e212cf60c68532fc4d9d09679')
+sha256sums=('79dee3b382b634623c3f32a835c2257a131c97022a824c318aee487619030b2e'
+ '3229b1bd653d2bb66dce15d01eebae17053cc40c2dac2997668e7468416faba3')
# https://github.com/returntocorp/semgrep/releases/download/v${pkgver}/semgrep-v${pkgver}-ubuntu-16.04.tgz.sha256
build() {
@@ -28,8 +28,6 @@ build() {
package() {
cd "${srcdir}"
find semgrep-files -type f -exec install -D '{}' "${pkgdir}/usr/lib/{}" \;
- mkdir -p "${pkgdir}/usr/bin"
- ln -s "/usr/lib/semgrep-files/semgrep-core" "${pkgdir}/usr/bin/semgrep-core"
cd "${_name}-${pkgver}"
python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build