summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAloxaf2020-09-15 19:46:43 +0800
committerAloxaf2020-09-15 19:46:43 +0800
commit39c4203495656b7422cfc5b7303ec86904489b70 (patch)
tree10a75a4e24108b5ea1a8ec311509750d47bd3634
parent2b1a2db434ab4a5e35f913d5f40ce09ad668f809 (diff)
downloadaur-39c4203495656b7422cfc5b7303ec86904489b70.tar.gz
Update to 0.23.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 69e6dc7abb64..a7490fb486a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = semgrep-bin
pkgdesc = Fast and syntax-aware semantic code pattern search for many languages: like grep but for code
- pkgver = 0.22.0
+ pkgver = 0.23.0
pkgrel = 1
url = https://github.com/returntocorp/semgrep
arch = x86_64
@@ -12,8 +12,8 @@ pkgbase = semgrep-bin
depends = openssl-1.0
provides = semgrep
options = !strip
- source = https://github.com/returntocorp/semgrep/releases/download/v0.22.0/semgrep-v0.22.0-ubuntu-16.04.tgz
- sha256sums = 4c4d7c7145b76a4bea115adda1d696705b98540fb97d0c8050d9d8fbf6ac8d68
+ source = https://github.com/returntocorp/semgrep/releases/download/v0.23.0/semgrep-v0.23.0-ubuntu-16.04.tgz
+ sha256sums = 50477fbce226b6223d78db1edf32e114aa21c43b8cea5d0b5d098b1b82db9060
pkgname = semgrep-bin
diff --git a/PKGBUILD b/PKGBUILD
index 4781e8dec785..bec685298089 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Aloxaf <aloxafx@gmail.com>
pkgname=semgrep-bin
-pkgver=0.22.0
+pkgver=0.23.0
pkgrel=1
pkgdesc="Fast and syntax-aware semantic code pattern search for many languages: like grep but for code"
arch=(x86_64)
@@ -11,13 +11,13 @@ depends=('bash' 'zlib' 'bzip2' 'ncurses5-compat-libs' 'openssl-1.0')
provides=('semgrep')
options=('!strip')
source=("https://github.com/returntocorp/semgrep/releases/download/v${pkgver}/semgrep-v${pkgver}-ubuntu-16.04.tgz")
-sha256sums=('4c4d7c7145b76a4bea115adda1d696705b98540fb97d0c8050d9d8fbf6ac8d68')
+sha256sums=('50477fbce226b6223d78db1edf32e114aa21c43b8cea5d0b5d098b1b82db9060')
# https://github.com/returntocorp/semgrep/releases/download/v${pkgver}/semgrep-v${pkgver}-ubuntu-16.04.tgz.sha256
package() {
cd "$srcdir"
find semgrep-files -type f -exec install -D '{}' "$pkgdir/usr/lib/{}" \;
mkdir -p "$pkgdir/usr/bin"
- ln -s "/usr/lib/semgrep-files/semgrep" "$pkgdir/usr/bin/semgrep"
+ ln -s "/usr/lib/semgrep-files/semgrep-core" "$pkgdir/usr/bin/semgrep"
ln -s "/usr/lib/semgrep-files/semgrep-core" "$pkgdir/usr/bin/semgrep-core"
}