summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAloxaf2021-04-03 00:08:04 +0800
committerAloxaf2021-04-03 00:08:04 +0800
commit5801264f9eb0adaf25d3526c958caa91f58115a7 (patch)
tree2abb37c4c6225c7d72d2d37dce8aab20175669d4
parent5fe6484fa692202f0fd6ac25f5e581305d288470 (diff)
downloadaur-5801264f9eb0adaf25d3526c958caa91f58115a7.tar.gz
Bump version to 0.45.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a4e6f893357..5d4bf447e966 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = semgrep-bin
pkgdesc = Fast and syntax-aware semantic code pattern search for many languages: like grep but for code
- pkgver = 0.44.0
+ pkgver = 0.45.0
pkgrel = 1
url = https://github.com/returntocorp/semgrep
arch = x86_64
@@ -18,10 +18,10 @@ pkgbase = semgrep-bin
depends = python-jsonschema
provides = semgrep
options = !strip
- source = https://github.com/returntocorp/semgrep/releases/download/v0.44.0/semgrep-v0.44.0-ubuntu-16.04.tgz
- source = https://files.pythonhosted.org/packages/source/s/semgrep/semgrep-0.44.0.tar.gz
- sha256sums = a7f948e5d76014ff8d93beee90ea764f49858ef636cdfb294dfd2839c17ba23e
- sha256sums = 8f99381f92c84832cab9c1552dbb2afce61833f21dbd829ec1d17e7ce937ecce
+ source = https://github.com/returntocorp/semgrep/releases/download/v0.45.0/semgrep-v0.45.0-ubuntu-16.04.tgz
+ source = https://files.pythonhosted.org/packages/source/s/semgrep/semgrep-0.45.0.tar.gz
+ sha256sums = 1c429ae5c5c672be1ff26569b2927a6c677481b20749c3f437aeb7c2e5106288
+ sha256sums = a2d24f622f17d1d89b9ec5b8dc42a9991bddebe7d4bc47b74de8d2d1b089eab6
pkgname = semgrep-bin
diff --git a/PKGBUILD b/PKGBUILD
index d9e9e65055fa..570480677572 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=semgrep-bin
_name=semgrep
-pkgver=0.44.0
+pkgver=0.45.0
pkgrel=1
pkgdesc="Fast and syntax-aware semantic code pattern search for many languages: like grep but for code"
arch=(x86_64)
@@ -17,8 +17,8 @@ source=(
"https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
)
sha256sums=(
- 'a7f948e5d76014ff8d93beee90ea764f49858ef636cdfb294dfd2839c17ba23e'
- '8f99381f92c84832cab9c1552dbb2afce61833f21dbd829ec1d17e7ce937ecce'
+ '1c429ae5c5c672be1ff26569b2927a6c677481b20749c3f437aeb7c2e5106288'
+ 'a2d24f622f17d1d89b9ec5b8dc42a9991bddebe7d4bc47b74de8d2d1b089eab6'
)
# https://github.com/returntocorp/semgrep/releases/download/v${pkgver}/semgrep-v${pkgver}-ubuntu-16.04.tgz.sha256
@@ -29,7 +29,7 @@ prepare() {
build() {
cd "$srcdir/${_name}-${pkgver}"
- sed -i 's/ruamel.yaml==0.16.10/ruamel.yaml>=0.16.10/' setup.py
+ sed -i 's/ruamel.yaml==0.17.0/ruamel.yaml>=0.17.0/' setup.py
python setup.py build
chmod +x build/lib/semgrep/bin/{semgrep-core,spacegrep}
}