summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAloxaf2020-05-23 10:08:34 +0800
committerAloxaf2020-05-23 10:08:34 +0800
commit597242eb89375acd718f712a6ff727b97fc40d67 (patch)
tree7e41f90c4dae8d6fdf475717addf2b0c8bf93044
downloadaur-597242eb89375acd718f712a6ff727b97fc40d67.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD23
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..59768a78a06d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = semgrep-bin
+ pkgdesc = Fast and syntax-aware semantic code pattern search for many languages: like grep but for code
+ pkgver = 0.8.0
+ pkgrel = 1
+ url = https://github.com/returntocorp/semgrep
+ arch = x86_64
+ license = LGPL2.1
+ depends = bash
+ depends = bzip2
+ depends = ncurses5-compat-libs
+ depends = openssl-1.0
+ provides = semgrep
+ options = !strip
+ source = https://github.com/returntocorp/semgrep/releases/download/v0.8.0/semgrep-v0.8.0-ubuntu-16.04.tgz
+ sha256sums = 30c91dcd4297aaf69e7a68c7024a6b21bd5160fce499f11aede6551d346b3f96
+
+pkgname = semgrep-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45c669c12f21
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Aloxaf <aloxafx@gmail.com>
+
+pkgname=semgrep-bin
+pkgver=0.8.0
+pkgrel=1
+pkgdesc="Fast and syntax-aware semantic code pattern search for many languages: like grep but for code"
+arch=(x86_64)
+url=https://github.com/returntocorp/semgrep
+license=(LGPL2.1)
+depends=('bash' 'zlib' 'bzip2' 'ncurses5-compat-libs' 'openssl-1.0')
+provides=('semgrep')
+options=('!strip')
+source=("https://github.com/returntocorp/semgrep/releases/download/v${pkgver}/semgrep-v${pkgver}-ubuntu-16.04.tgz")
+sha256sums=('30c91dcd4297aaf69e7a68c7024a6b21bd5160fce499f11aede6551d346b3f96')
+# https://github.com/returntocorp/semgrep/releases/download/v${pkgver}/semgrep-v${pkgver}-ubuntu-16.04.tgz.sha256
+
+package() {
+ cd "$srcdir"
+ find semgrep-files -type f -exec install -D '{}' "$pkgdir/usr/lib/{}" \;
+ mkdir -p "$pkgdir/usr/bin"
+ ln -s "/usr/lib/semgrep-files/semgrep" "$pkgdir/usr/bin/semgrep"
+ ln -s "/usr/lib/semgrep-files/semgrep-core" "$pkgdir/usr/bin/semgrep-core"
+}