summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAloxaf2021-12-12 11:47:23 +0800
committerAloxaf2021-12-12 11:47:23 +0800
commitcbeb0421cf79b1679740efea252887bad5757add (patch)
tree3175edabd9127eda954550279b87b79dad1d7a8b
parent73567817363b63dd037f4f2a5f6da438f2340ee8 (diff)
downloadaur-cbeb0421cf79b1679740efea252887bad5757add.tar.gz
Bump to 0.76.2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d63a88c6c42..d3469f9d2dbf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = semgrep-bin
pkgdesc = Fast and syntax-aware semantic code pattern search for many languages: like grep but for code
- pkgver = 0.63.0
+ pkgver = 0.76.2
pkgrel = 1
url = https://github.com/returntocorp/semgrep
arch = x86_64
@@ -10,6 +10,8 @@ pkgbase = semgrep-bin
depends = python
depends = python-attrs
depends = python-colorama
+ depends = python-click
+ depends = python-click-option-group
depends = python-requests
depends = python-ruamel-yaml
depends = python-tqdm
@@ -19,9 +21,9 @@ pkgbase = semgrep-bin
depends = python-peewee
provides = semgrep
options = !strip
- source = https://github.com/returntocorp/semgrep/releases/download/v0.63.0/semgrep-v0.63.0-ubuntu-16.04.tgz
- source = https://files.pythonhosted.org/packages/source/s/semgrep/semgrep-0.63.0.tar.gz
- sha256sums = 14f29fe824f9fa288e5e6c0f6e48f0a11dcacd1878073c699873b62df3827e50
- sha256sums = 777322ce3bbe07a43cc5e8d9ad23691441d3af9785e942134ceb5bdad1eb4902
+ source = https://github.com/returntocorp/semgrep/releases/download/v0.76.2/semgrep-v0.76.2-ubuntu-16.04.tgz
+ source = https://files.pythonhosted.org/packages/source/s/semgrep/semgrep-0.76.2.tar.gz
+ sha256sums = 99f592b75faa7be1cb60c735b56ddb213d00e83073094b9cefa957cb3b4a6a7c
+ sha256sums = f526e94c3a2d5be23557490861c5e0175f907547aa71c04e943a05c7a3fdb34d
pkgname = semgrep-bin
diff --git a/PKGBUILD b/PKGBUILD
index 1e46c4e07f48..275934481f40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=semgrep-bin
_name=semgrep
-pkgver=0.63.0
+pkgver=0.76.2
pkgrel=1
pkgdesc="Fast and syntax-aware semantic code pattern search for many languages: like grep but for code"
arch=(x86_64)
url=https://github.com/returntocorp/semgrep
license=(LGPL2.1)
makedepends=('python-setuptools' 'python-wheel')
-depends=('python' 'python-attrs' 'python-colorama' 'python-requests' 'python-ruamel-yaml' 'python-tqdm' 'python-packaging' 'python-jsonschema' 'python-wcmatch' 'python-peewee')
+depends=('python' 'python-attrs' 'python-colorama' 'python-click' 'python-click-option-group' 'python-requests' 'python-ruamel-yaml' 'python-tqdm' 'python-packaging' 'python-jsonschema' 'python-wcmatch' 'python-peewee')
provides=('semgrep')
options=('!strip')
source=(
@@ -17,8 +17,8 @@ source=(
"https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
)
sha256sums=(
- '14f29fe824f9fa288e5e6c0f6e48f0a11dcacd1878073c699873b62df3827e50'
- '777322ce3bbe07a43cc5e8d9ad23691441d3af9785e942134ceb5bdad1eb4902'
+ '99f592b75faa7be1cb60c735b56ddb213d00e83073094b9cefa957cb3b4a6a7c'
+ 'f526e94c3a2d5be23557490861c5e0175f907547aa71c04e943a05c7a3fdb34d'
)
# https://github.com/returntocorp/semgrep/releases/download/v${pkgver}/semgrep-v${pkgver}-ubuntu-16.04.tgz.sha256
@@ -26,6 +26,8 @@ build() {
cd "$srcdir/${_name}-${pkgver}"
export SEMGREP_CORE_BIN="${srcdir}/semgrep-files/semgrep-core"
export SPACEGREP_BIN="${srcdir}/semgrep-files/spacegrep"
+ # TODO: remove this when upstream update
+ sed -i 's/wcmatch==8.2/wcmatch>=8.2/' setup.py
python setup.py build
chmod +x build/lib/semgrep/bin/{semgrep-core,spacegrep}
}