summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2017-08-11 13:56:40 +0200
committerNicolas Iooss2017-08-11 13:56:40 +0200
commit49e692a0999e2008d96ebc91499fcb8e5ac3a064 (patch)
tree1f4a2e50290a87c5e78f99fef448879477fd7ff6
downloadaur-49e692a0999e2008d96ebc91499fcb8e5ac3a064.tar.gz
Create semodule-utils package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..580f168fca4f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = semodule-utils
+ pkgdesc = SELinux module tools
+ pkgver = 2.7
+ pkgrel = 1
+ url = https://github.com/SELinuxProject/selinux/wiki
+ arch = i686
+ arch = x86_64
+ groups = selinux
+ license = GPL2
+ depends = libsepol>=2.7
+ conflicts = policycoreutils<2.7
+ source = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20170804/semodule-utils-2.7.tar.gz
+ sha256sums = 90c98b3362a43b4da2a51a9176820a56f3e615225e23e3395bc566c4490786ba
+
+pkgname = semodule-utils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b9343f835a92
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
+
+pkgname=semodule-utils
+pkgver=2.7
+pkgrel=1
+pkgdesc="SELinux module tools"
+arch=('i686' 'x86_64')
+url='https://github.com/SELinuxProject/selinux/wiki'
+license=('GPL2')
+groups=('selinux')
+depends=('libsepol>=2.7')
+conflicts=('policycoreutils<2.7')
+source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20170804/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('90c98b3362a43b4da2a51a9176820a56f3e615225e23e3395bc566c4490786ba')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" LIBSEPOLA=/usr/lib/libsepol.a install
+}