summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYizheng Hu2020-11-19 16:56:52 +0800
committerYizheng Hu2020-11-19 16:56:52 +0800
commit2400e7f926523036968e3a3f538b931a2d271509 (patch)
tree93b216c9d80d203865f07eb1d57bc92789ce5a53
parent14c03572e7a85a0606b83f647cde285312f063b7 (diff)
downloadaur-2400e7f926523036968e3a3f538b931a2d271509.tar.gz
Update
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD44
2 files changed, 38 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d239908cad62..6f9181d17f49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,15 @@
pkgbase = sendanywhere
pkgdesc = Send Anywhere is a multi-platform file sharing service where users can directly share digital content in real time.
- pkgver = 9.3.5
+ pkgver = 20.3.13
pkgrel = 1
url = http://send-anywhere.com
arch = x86_64
license = custom
- depends = gconf
- depends = libxtst
- depends = nss
- depends = libxss
- depends = alsa-lib
- depends = gtk2
- source = sendanywhere-9.3.5.deb::https://update.send-anywhere.com/linux_downloads/sendanywhere_latest_amd64.deb
+ depends = electron8
+ makedepends = asar
+ source = sendanywhere-20.3.13.deb::https://update.send-anywhere.com/linux_downloads/sendanywhere_latest_amd64.deb
source = LICENSE
- sha512sums = ae3799a2822284dedeff3e48bbab8cae9407abe98eb96e91e701261b266e000428be25daf322d0ebde55f0393986bc83e89efed3d36c67f3d0163641c1f9af9f
+ sha512sums = 2ad10e770ea84150845b3033177da4125a5c93651a14969566a43a305a8cc6c2c338c10d04ea10b3b48a225cc331170732589b5805d67486cc02b0e84ab5eb56
sha512sums = aeb97a12f246d78cbf202354148b429a037997d68087bceed5d5ce5036443d779c2535138b54347579ddf05994a61b9333913f9261733f367d02e0e9cf7d0b5e
pkgname = sendanywhere
diff --git a/PKGBUILD b/PKGBUILD
index d2828fa85afd..b3a4e0a236bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,54 @@
-# Maintainer: Ye Shu <shuye02@outlook.com>
+# Maintainer: Yizheng Hu <huyizheng@hotmail.com>
+# Contributor: Ye Shu <shuye02@outlook.com>
# Contributor: Aaron Fischer <mail@aaron-fischer.net>
# Contributor: Ashwin Vishnu <ashuwish+arch at gmail dot com>
pkgname=sendanywhere
-pkgver=9.3.5
+pkgver=20.3.13
pkgrel=1
arch=('x86_64')
pkgdesc="Send Anywhere is a multi-platform file sharing service where users can directly share digital content in real time."
url="http://send-anywhere.com"
license=('custom')
-depends=('gconf' 'libxtst' 'nss' 'libxss' 'alsa-lib' 'gtk2')
+depends=('electron8')
+makedepends=('asar')
source=("${pkgname}-${pkgver}.deb::https://update.send-anywhere.com/linux_downloads/sendanywhere_latest_amd64.deb" "LICENSE")
-sha512sums=('ae3799a2822284dedeff3e48bbab8cae9407abe98eb96e91e701261b266e000428be25daf322d0ebde55f0393986bc83e89efed3d36c67f3d0163641c1f9af9f'
+sha512sums=('2ad10e770ea84150845b3033177da4125a5c93651a14969566a43a305a8cc6c2c338c10d04ea10b3b48a225cc331170732589b5805d67486cc02b0e84ab5eb56'
'aeb97a12f246d78cbf202354148b429a037997d68087bceed5d5ce5036443d779c2535138b54347579ddf05994a61b9333913f9261733f367d02e0e9cf7d0b5e')
# If validity check fails, please leave a comment to remind me to update the package version
package(){
# Extract the data package
- tar -xf data.tar.xz --directory="$pkgdir"
+ tar -xf data.tar.xz
+ cd $srcdir/opt/SendAnywhere
- # Add licenses
- install -Dm644 $srcdir/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 "$pkgdir/opt/SendAnywhere/LICENSE.electron.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.electron.txt"
- install -Dm644 "$pkgdir/opt/SendAnywhere/LICENSES.chromium.html" "$pkgdir/usr/share/licenses/$pkgname/LICENSES.chromium.html"
+ mkdir -p $pkgdir/usr/lib/$pkgname
+
+ # HACKS FOR SYSTEM ELECTRON
+ asar e resources/app.asar resources/app
+ sed -i "s|,\"paprika.node\"|,\"/usr/lib/$pkgname/paprika.node\"|" resources/app/src/main/main.prod.js
+ export electronVersion=$(tail -1 /usr/lib/electron8/version | cut -d '.' -f 1,2)
+ ln -s electron-v8.0-linux-x64 resources/app/node_modules/sqlite3/lib/binding/electron-v$electronVersion-linux-x64
+
+ # Copy Relevanat data
+ cp -r resources/* $pkgdir/usr/lib/$pkgname/
+ rm $pkgdir/usr/lib/$pkgname/app.asar
+ cp paprika.node $pkgdir/usr/lib/$pkgname/
+
+ cd $srcdir
- # Create soft link
+ # Create starter script
+ echo "#!/bin/sh" >> $pkgname
+ echo "exec electron8 /usr/lib/$pkgname/app \$@" >> $pkgname
mkdir -p $pkgdir/usr/bin
- ln -sf "/opt/SendAnywhere/SendAnywhere" "$pkgdir/usr/bin/SendAnywhere"
+ install -Dm 755 $pkgname $pkgdir/usr/bin/$pkgname
+
+ # Install .desktop and icon
+ cp -r usr/share $pkgdir/usr/
+ sed -i "s|Exec=.*|Exec=/usr/bin/$pkgname|" $pkgdir/usr/share/applications/SendAnywhere.desktop
+
+ # Add licenses
+ install -Dm644 $srcdir/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}