summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormoparisthebest2017-01-10 13:28:49 -0500
committermoparisthebest2017-01-10 13:28:49 -0500
commit52a325209e20320c4dda63a349258d441ccb2dc1 (patch)
treec8439635c4f313d1db976075612a94f1eb9ed3d1
downloadaur-52a325209e20320c4dda63a349258d441ccb2dc1.tar.gz
First version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD20
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe3319c59d03
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = sendxmpp-py
+ pkgdesc = sendxmpp is the XMPP equivalent of sendmail. It is an alternative to the old sendxmpp written in Perl.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/moparisthebest/sendxmpp-py
+ arch = any
+ license = GPL3
+ depends = python-dnspython
+ depends = python-sleekxmpp
+ depends = python
+ provides = sendxmpp
+ conflicts = sendxmpp
+ source = https://codeload.github.com/moparisthebest/sendxmpp-py/tar.gz/v1.0
+ sha256sums = 50fa7fdb38291aa2d49e330f4fb627ae1bb671572fbc1682b8b82593d34c45e2
+
+pkgname = sendxmpp-py
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa62d75f0188
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Contributor: moparisthebest <admin dot archlinux AT moparisthebest dot com>
+
+pkgname=sendxmpp-py
+pkgver=1.0
+pkgrel=1
+pkgdesc='sendxmpp is the XMPP equivalent of sendmail. It is an alternative to the old sendxmpp written in Perl.'
+arch=('any')
+license=('GPL3')
+depends=('python-dnspython' 'python-sleekxmpp' 'python')
+provides=('sendxmpp')
+conflicts=('sendxmpp')
+url="https://github.com/moparisthebest/sendxmpp-py"
+source=("https://codeload.github.com/moparisthebest/sendxmpp-py/tar.gz/v$pkgver")
+sha256sums=('50fa7fdb38291aa2d49e330f4fb627ae1bb671572fbc1682b8b82593d34c45e2')
+
+package() {
+ cd "sendxmpp-py-$pkgver"
+ install -D -m755 sendxmpp "${pkgdir}"/usr/bin/sendxmpp
+ install -D -m755 sendxmpp.cfg "${pkgdir}"/etc/sendxmpp/sendxmpp.cfg
+}