summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Barri2021-05-08 13:18:16 +1000
committerDavid Barri2021-05-08 13:18:16 +1000
commit88728085b512e7731c53e94ff7de7eeaabcb775d (patch)
tree4b100a9fed2f9973d2da85ce328a0c4891f00228
downloadaur-88728085b512e7731c53e94ff7de7eeaabcb775d.tar.gz
Init @ v1.2 with pipewire support
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD37
-rw-r--r--aur-cfg.sh7
4 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c466d7161d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = sennheiser-gsp670-pulseaudio-profile
+ pkgdesc = PulseAudio profile for the Sennheiser GSP 670 wireless gaming headset
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://github.com/szszoke/sennheiser-gsp670-pulseaudio-profile
+ arch = any
+ license = MIT
+ source = https://github.com/szszoke/sennheiser-gsp670-pulseaudio-profile/archive/refs/tags/1.2.tar.gz
+ sha256sums = d69b1f3cb05f70fdc0115930623407a228e8bb9d4ed9fc3cdff69aab502092ae
+
+pkgname = sennheiser-gsp670-pulseaudio-profile
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cb3ee1d6ae04
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.pkg.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..69fd88d4f895
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: David Barri <japgolly@gmail.com>
+pkgname=sennheiser-gsp670-pulseaudio-profile
+pkgver=1.2
+pkgrel=1
+pkgdesc="PulseAudio profile for the Sennheiser GSP 670 wireless gaming headset"
+arch=('any')
+url="https://github.com/szszoke/sennheiser-gsp670-pulseaudio-profile"
+license=('MIT')
+source=("$url/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('d69b1f3cb05f70fdc0115930623407a228e8bb9d4ed9fc3cdff69aab502092ae')
+
+package() {
+ set -eu
+
+ cd sennheiser-gsp670-pulseaudio-profile-$pkgver
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ rules=91-pulseaudio-sennheiser-gsp670.rules
+ rules2=$rules.2
+ perl -pe 's/(, *ENV\{PULSE_PROFILE_SET}(=".+?"))/$1, ENV{ACP_PROFILE_SET}$2/' <$rules >$rules2
+ install -Dm644 $rules2 "$pkgdir/etc/udev/rules.d/$rules"
+
+ function install_into {
+ path="$1"
+ mkdir -p "$pkgdir/$path/"{profile-sets,paths}
+ install -m644 sennheiser-gsp670-usb-audio.conf "$pkgdir/$path/profile-sets/"
+ install -m644 sennheiser-gsp670-output-main.conf "$pkgdir/$path/paths/"
+ install -m644 sennheiser-gsp670-output-comm.conf "$pkgdir/$path/paths/"
+ install -m644 sennheiser-gsp670-input-comm.conf "$pkgdir/$path/paths/"
+ }
+
+ install_into /usr/share/alsa-card-profile/mixer
+ install_into /usr/share/pulseaudio/alsa-mixer
+
+ # tree $pkgdir
+}
diff --git a/aur-cfg.sh b/aur-cfg.sh
new file mode 100644
index 000000000000..8367a6c2336b
--- /dev/null
+++ b/aur-cfg.sh
@@ -0,0 +1,7 @@
+function get_latest_version {
+ curl -s https://github.com/szszoke/sennheiser-gsp670-pulseaudio-profile/releases/latest | perl -pe 's!.*/tag/(.+?)".*!$1!'
+}
+
+function clean_downloads {
+ rm -rf *.tar.gz
+}