aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBao Trinh2023-06-24 22:55:54 -0700
committerTechcable2023-06-25 02:07:50 -0700
commit7f56e94f3345e0e5d95a19235a5a91744277813e (patch)
tree30f268eb7512a375821bb7c0ea529d9cd45d8568
parent4be4ed4c68d5f1022f09e10714e2ef5586bdf52e (diff)
downloadaur-7f56e94f3345e0e5d95a19235a5a91744277813e.tar.gz
Update to senpai v0.2.0
Release notes: https://git.sr.ht/~taiite/senpai/refs/v0.2.0 Reduced the PKGBUILD by calling make instead of manually building and cp'ing each file Add license file
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Temporary-hack-to-workaround-WHO-flooding-bug.patch38
-rw-r--r--PKGBUILD28
3 files changed, 11 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1db8c93700f1..d43b19827ae0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = senpai-irc
pkgdesc = TUI IRC Client Created by ~taiite
- pkgver = 0.1.0
+ pkgver = 0.2.0
pkgrel = 1
url = https://sr.ht/~taiite/senpai/
arch = x86_64
@@ -10,9 +10,7 @@ pkgbase = senpai-irc
makedepends = scdoc
conflicts = senpai-irc-git
conflicts = senpai
- source = senpai-v0.1.0.tar.gz::https://git.sr.ht/~taiite/senpai/archive/v0.1.0.tar.gz
- source = 0001-Temporary-hack-to-workaround-WHO-flooding-bug.patch
- sha256sums = 98e1f16ed97433e1e8c8bdabac1cac1920ddcab90e6cef36d8817a41b45a94ff
- sha256sums = e86dc1bcb4d7cd1c39ed38a7b5c036065345a5af9b9f119762997e109cd22ceb
+ source = senpai-v0.2.0.tar.gz::https://git.sr.ht/~taiite/senpai/archive/v0.2.0.tar.gz
+ sha256sums = 9786fd83f3e1067549c3c88455a1f66ec66d993fe597cee334d217a5d1cf4803
pkgname = senpai-irc
diff --git a/0001-Temporary-hack-to-workaround-WHO-flooding-bug.patch b/0001-Temporary-hack-to-workaround-WHO-flooding-bug.patch
deleted file mode 100644
index 0a71f2dd982a..000000000000
--- a/0001-Temporary-hack-to-workaround-WHO-flooding-bug.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 5017e864ac5a4dbe7e97920c24e39a4dae89e92c Mon Sep 17 00:00:00 2001
-From: Techcable <Techcable@techcable.net>
-Date: Wed, 10 Aug 2022 15:19:17 -0700
-Subject: [PATCH] Temporary hack to workaround WHO flooding bug
-
-From #senpai IRC:
-<cc0> yeah thats a known bug, will be fixed later with a soju patch
-<Techcable> Oh, it's a soju problem?
-<Techcable> Here's the soju log if that's helpful: https://paste.sr.ht/~techcable/23d75d1d75ecda9a02ba0238bf524f4d8ffa7622
-<cc0> this just affects the initial view of whether people are here or away (shown in grey)
-<Techcable> Cool - I'll probably patch senpai to disable WHO status in the meantime ;)
-<cc0> are you getting flooded with these error messages or is it just printed once?
----
- irc/session.go | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/irc/session.go b/irc/session.go
-index 0776436..6275862 100644
---- a/irc/session.go
-+++ b/irc/session.go
-@@ -790,12 +790,12 @@ func (s *Session) handleMessageRegistered(msg Message, playback bool) (Event, er
- Name: msg.Params[0],
- Members: map[*User]string{},
- }
-- if _, ok := s.enabledCaps["away-notify"]; ok {
-+ /* if _, ok := s.enabledCaps["away-notify"]; ok {
- // Only try to know who is away if the list is
- // updated by the server via away-notify.
- // Otherwise, it'll become outdated over time.
- s.out <- NewMessage("WHO", channel)
-- }
-+ } */
- } else if c, ok := s.channels[channelCf]; ok {
- if _, ok := s.users[nickCf]; !ok {
- s.users[nickCf] = &User{Name: msg.Prefix.Copy()}
---
-2.32.1 (Apple Git-133)
-
diff --git a/PKGBUILD b/PKGBUILD
index 7290dccaebb5..abd3a6a68858 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Techcable <$username @ techcable.net>
# Contributor: Dan Shick <dan.shick@gmail.com>
+# Contributor: Bao Trinh <qubidt at gmail dot com>
pkgname=senpai-irc
-pkgver=0.1.0
+pkgver=0.2.0
pkgrel=1
pkgdesc='TUI IRC Client Created by ~taiite'
url=https://sr.ht/~taiite/senpai/
@@ -19,17 +20,11 @@ license=('ISC')
# Also the binary is aliased to "senpai-irc" as a secondary name
conflicts=('senpai-irc-git' 'senpai')
makedepends=('go' 'scdoc')
-source=(
- "senpai-v${pkgver}.tar.gz::https://git.sr.ht/~taiite/senpai/archive/v0.1.0.tar.gz"
- # This is needed until issue 95 is resolved: https://todo.sr.ht/~taiite/senpai/95
- "0001-Temporary-hack-to-workaround-WHO-flooding-bug.patch"
-)
-sha256sums=('98e1f16ed97433e1e8c8bdabac1cac1920ddcab90e6cef36d8817a41b45a94ff'
- 'e86dc1bcb4d7cd1c39ed38a7b5c036065345a5af9b9f119762997e109cd22ceb')
+source=("senpai-v${pkgver}.tar.gz::https://git.sr.ht/~taiite/senpai/archive/v${pkgver}.tar.gz")
+sha256sums=('9786fd83f3e1067549c3c88455a1f66ec66d993fe597cee334d217a5d1cf4803')
prepare () {
cd "${srcdir}/senpai-v${pkgver}"
- patch --strip=1 --input="${srcdir}/0001-Temporary-hack-to-workaround-WHO-flooding-bug.patch"
make clean
}
@@ -39,20 +34,13 @@ build () {
export CGO_CFLAGS="${CFLAGS}"
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- go build ./cmd/senpai
- make doc/senpai.1
- make doc/senpai.5
+ make GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw" all
}
package () {
- mkdir -p "${pkgdir}/usr/bin"
- mkdir -p "${pkgdir}/usr/share/man/man1"
- mkdir -p "${pkgdir}/usr/share/man/man5"
- cp "${srcdir}/senpai-v${pkgver}/senpai" "${pkgdir}/usr/bin/senpai"
- cp "${srcdir}/senpai-v${pkgver}/doc/senpai.1" "${pkgdir}/usr/share/man/man1/"
- cp "${srcdir}/senpai-v${pkgver}/doc/senpai.5" "${pkgdir}/usr/share/man/man5/"
+ cd "${srcdir}/senpai-v${pkgver}"
+ make "DESTDIR=${pkgdir}" "PREFIX=/usr" install
# Alias binary as "senpai-irc" (gives compat with senpai-irc-git)
ln -s "${pkgdir}/usr/bin/senpai" "senpai-irc"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-