summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPřemysl Eric Janouch2020-10-12 15:56:12 +0200
committerPřemysl Eric Janouch2020-10-12 15:56:12 +0200
commit2e18365a60e92bf4460700208402a61585b87b0c (patch)
treecc23df0a56925384d87af71ad1ea1e77428a583f
parent151e877a92aae84a16a0a92d79d6810248669652 (diff)
downloadaur-2e18365a60e92bf4460700208402a61585b87b0c.tar.gz
Bump and fix up this mess a bit
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d22be33c97fe..906fdf574404 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = sensei-raw-ctl
pkgdesc = SteelSeries Sensei Raw configuration tool
- pkgver = 2f70930
- pkgrel = 3
+ pkgver = r47.gbe98666
+ pkgrel = 1
url = https://git.janouch.name/p/sensei-raw-ctl
arch = i686
arch = x86_64
- license = Custom
+ license = custom:0BSD
makedepends = git
makedepends = make
makedepends = cmake
makedepends = help2man
provides = sensei-raw-ctl
- source = git+https://git.janouch.name/p/sensei-raw-ctl.git#commit=2f70930
+ source = git+https://git.janouch.name/p/sensei-raw-ctl.git#commit=be98666
md5sums = SKIP
pkgname = sensei-raw-ctl
diff --git a/PKGBUILD b/PKGBUILD
index 950c2459a383..357aed51af10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
-# Maintainer: Dave Simons <pkgs@simonsd.org>
-
+# Maintainer: Přemysl Eric Janouch <p@janouch.name>
pkgname=sensei-raw-ctl
-pkgver=2f70930
-pkgrel=3
+pkgver=r47.gbe98666
+pkgrel=1
pkgdesc="SteelSeries Sensei Raw configuration tool"
arch=('i686' 'x86_64')
url="https://git.janouch.name/p/sensei-raw-ctl"
makedepends=('git' 'make' 'cmake' 'help2man')
provides=('sensei-raw-ctl')
-source=('git+https://git.janouch.name/p/sensei-raw-ctl.git#commit=2f70930')
+source=('git+https://git.janouch.name/p/sensei-raw-ctl.git#commit=be98666')
md5sums=('SKIP')
-license=('Custom')
+license=('custom:0BSD')
build() {
cd "$srcdir/$pkgname"
- rm .git* -rf
cmake . -DCMAKE_INSTALL_PREFIX=$pkgdir/usr -DBUILD_GUI=NO
}
package() {
cd "$srcdir/$pkgname"
make install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}