summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorL. Bradley LaBoon2019-02-27 16:09:26 -0500
committerL. Bradley LaBoon2019-02-27 16:09:26 -0500
commit8e32909e8ac7ee153edfe285016ea08fec3a6657 (patch)
tree0aab2f033607547743ef4ffa91fa1328c20f7111
downloadaur-8e32909e8ac7ee153edfe285016ea08fec3a6657.tar.gz
Initial commit. Version 6.6.1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..62eb7d6cd69e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = sentinl
+ pkgdesc = Siren Platform + Kibana Alert & Report App for Elasticsearch
+ pkgver = 6.6.1
+ pkgrel = 1
+ url = https://github.com/sirensolutions/sentinl
+ arch = any
+ license = Apache
+ depends = kibana=6.6.1
+ source = https://github.com/sirensolutions/sentinl/releases/download/tag-6.6.0-0/sentinl-v6.6.1.zip
+ sha256sums = 9d226cf0c63f290474f723a3e922f2119a3f3ee2af3488b02e6f9954b20b00f8
+
+pkgname = sentinl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7cb61c1a1528
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: L. Bradley LaBoon <me@bradleylaboon.com>
+pkgname=sentinl
+basever=6.6
+pkgver=${basever}.1
+pkgrel=1
+pkgdesc="Siren Platform + Kibana Alert & Report App for Elasticsearch"
+url="https://github.com/sirensolutions/sentinl"
+arch=('any')
+license=('Apache')
+depends=("kibana=$pkgver")
+source=("https://github.com/sirensolutions/sentinl/releases/download/tag-${basever}.0-0/sentinl-v${pkgver}.zip")
+sha256sums=('9d226cf0c63f290474f723a3e922f2119a3f3ee2af3488b02e6f9954b20b00f8')
+
+package() {
+ cd "$srcdir"
+ install -dm 0755 "$pkgdir/usr/share/kibana/plugins"
+ cp -r "$srcdir/kibana/$pkgname" "$pkgdir/usr/share/kibana/plugins"
+}