summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin A. Shelton2019-04-18 21:44:13 -0600
committerBenjamin A. Shelton2019-04-18 21:44:13 -0600
commit0ac468c9dc1388ae89612116d13f845ada266242 (patch)
treeb0aed229800affd87f2229ea0518132abaf37989
parent34c75b0161b2da39645751a14bd0b27ee1edc00d (diff)
downloadaur-0ac468c9dc1388ae89612116d13f845ada266242.tar.gz
Dependency cleanup (see below).
Dependencies have been trimmed down, particularly PostgreSQL (PKGBUILD now only relies on postgresql-libs) and a few others. llvm has been moved to `makedepends` and Redis has been added to `optdepends`. Redis is still required for sentry-celery to function, but because Sentry can be installed on a server different from that hosting Redis, I've relented and moved it into `optdepends`. I'm not sure this is the best place to move Redis since it's not an optional dependency, but I also don't want Sentry to have a hard dependency on Redis in circumstances where a server or container might be spun up specifically for Sentry support when a Redis cluster resides elsewhere. If this causes issues with other users, I may revert the change. I'm hoping to leave it as is, because if you really need Sentry installed, you probably ought to know a bit about what its requirements are for self-hosting the on-premise version. Minio has also been mentioned in the optdepends.
-rw-r--r--PKGBUILD19
1 files changed, 15 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8ee070980bb7..08a6f2106a97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,29 +4,40 @@
pkgbase=sentry
pkgname=('sentry')
pkgver=9.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Python-based realtime logging and aggregation server."
arch=(any)
url="http://pypi.python.org/pypi/sentry"
license=(BSD)
makedepends=(
'clang'
+ 'llvm'
'python2-pip'
'python2-setuptools'
'python2-virtualenv'
)
install='sentry.install'
+
depends=(
'jansson'
'libjpeg-turbo'
'libxml2'
'libxslt'
- 'llvm'
'ncurses5-compat-libs'
'python2'
- 'postgresql'
- 'redis'
+ 'postgresql-libs'
)
+
+# Redis is declared in the `optdepends` array because it is a "soft"
+# dependency. sentry-celery requires it for background task processing and
+# pub/sub, but it need not run on the same server as Sentry. As of 9.1.0-2,
+# Redis has been removed from `depends` to ease the dependency requiresments
+# of users running Sentry on a separate server or container.
+optdepends=(
+ 'minio: self-hosted S3-compatible file storage backend'
+ 'redis: required by sentry-celery but need not run on the same server'
+)
+
options=(!strip)
source=(
"sentry.install"