summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin A. Shelton2019-04-23 14:54:47 -0600
committerBenjamin A. Shelton2019-04-23 14:54:47 -0600
commit9145d1c22fe5e272479976129b7072666e8962cb (patch)
treeaf66372397a0e0b5bf8d84dc3bba31a298b60741
parent0d63b3139469586a6d03ad861d22ea418821e471 (diff)
downloadaur-9145d1c22fe5e272479976129b7072666e8962cb.tar.gz
Bumped version to v9.1.1 and cleaned up dependencies.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
-rw-r--r--sentry.install151
3 files changed, 113 insertions, 60 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5a9eba431d8..43b485b349ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
# Generated by mksrcinfo v8
-# Fri Apr 19 03:48:16 UTC 2019
+# Tue Apr 23 20:54:39 UTC 2019
pkgbase = sentry
pkgdesc = Python-based realtime logging and aggregation server.
- pkgver = 9.1.0
- pkgrel = 2
+ pkgver = 9.1.1
+ pkgrel = 1
url = http://pypi.python.org/pypi/sentry
install = sentry.install
arch = any
license = BSD
- makedepends = clang
- makedepends = llvm
makedepends = python2-pip
makedepends = python2-setuptools
makedepends = python2-virtualenv
@@ -17,9 +15,9 @@ pkgbase = sentry
depends = libjpeg-turbo
depends = libxml2
depends = libxslt
- depends = ncurses5-compat-libs
depends = python2
depends = postgresql-libs
+ optdepends = llvm: required for dsym support
optdepends = minio: self-hosted S3-compatible file storage backend
optdepends = redis: required by sentry-celery but need not run on the same server
options = !strip
@@ -30,7 +28,7 @@ pkgbase = sentry
source = sentry-web.service
source = sentry.target
source = sentry-sysusers.conf
- sha256sums = f546dfbb4c3dac72a9588f18c7dca668b680ddc4d8878f54b174756acc6de2bf
+ sha256sums = 3be04bc47f4f037bf157da9986874c343e6c7d1af9e30269b4f0aabf303d3291
sha256sums = d60b097721ec4acbc5b1232a0f29ef9d21d60228d17db655848a8e2a5c9a5281
sha256sums = d22b9bde7c39d9d0f031ba1b01c955c9dbe4ffe3f3f083875fe557f75f0050f7
sha256sums = 3c471417a279ac6605d3bb82b7377eaab0e24efe9cf582a11eef0d9e4c89428e
diff --git a/PKGBUILD b/PKGBUILD
index 08a6f2106a97..513c2bff7a79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,13 @@
pkgbase=sentry
pkgname=('sentry')
-pkgver=9.1.0
-pkgrel=2
+pkgver=9.1.1
+pkgrel=1
pkgdesc="Python-based realtime logging and aggregation server."
arch=(any)
url="http://pypi.python.org/pypi/sentry"
license=(BSD)
makedepends=(
- 'clang'
- 'llvm'
'python2-pip'
'python2-setuptools'
'python2-virtualenv'
@@ -23,7 +21,6 @@ depends=(
'libjpeg-turbo'
'libxml2'
'libxslt'
- 'ncurses5-compat-libs'
'python2'
'postgresql-libs'
)
@@ -34,6 +31,7 @@ depends=(
# Redis has been removed from `depends` to ease the dependency requiresments
# of users running Sentry on a separate server or container.
optdepends=(
+ 'llvm: required for dsym support'
'minio: self-hosted S3-compatible file storage backend'
'redis: required by sentry-celery but need not run on the same server'
)
@@ -49,7 +47,7 @@ source=(
"sentry-sysusers.conf"
)
sha256sums=(
- f546dfbb4c3dac72a9588f18c7dca668b680ddc4d8878f54b174756acc6de2bf # sentry.install
+ 3be04bc47f4f037bf157da9986874c343e6c7d1af9e30269b4f0aabf303d3291 # sentry.install
d60b097721ec4acbc5b1232a0f29ef9d21d60228d17db655848a8e2a5c9a5281 # sentry-celery.service
d22b9bde7c39d9d0f031ba1b01c955c9dbe4ffe3f3f083875fe557f75f0050f7 # sentry-cron.service
3c471417a279ac6605d3bb82b7377eaab0e24efe9cf582a11eef0d9e4c89428e # sentry.service
diff --git a/sentry.install b/sentry.install
index efb074411277..e4c312918052 100644
--- a/sentry.install
+++ b/sentry.install
@@ -37,6 +37,37 @@ If you wish to run Sentry manually, e.g. to test your configuration:
sudo -u sentry /opt/sentry/bin/sentry --config=/etc/sentry run web
+REDIS
+
+In order to facilitate installing Sentry on a containerized system (e.g.
+systemd-nspawn), we have removed Redis from the "depends" array in the
+PKGBUILD. Redis is still REQUIRED and sentry-celery will not run without it;
+however, for users where the installation of extra services and daemons may be
+an issue, we've been experimenting with trimming down hard dependencies. If
+you find sentry-celery fails to run, you will need to configure a Redis
+instance either locally or remotely.
+
+OPTIONAL DEPENDENCIES
+
+We've removed LLVM from the "depends" array as part of our dependency cleanup
+to make life a little bit easier for those who have been requesting reduced
+dependency builds for quite some time. Now, you should no longer need to
+modify the PKGBUILD prior to build or installation. Please note that projects
+making use of dsym (symsynd) still require the presence of LLVM. It has been
+moved to "optdepends" for this reason.
+
+IF THE INSTALL FAILS DURING DATABASE MIGRATIONS
+
+By default, Sentry wants to run as the PostgreSQL super user "postgres". This
+is probably undesirable, but Sentry will not install otherwise. As a
+workaround, you have two options: 1) Configure the user running Sentry as
+a user temporarily for installation (removing super user access afterwards) or
+2) perform the installation with the "postgres" user and change the database
+permissions after the migrations have completed. For information on changing
+table and sequence permissions, see the Stack Overflow answer here:
+
+ https://stackoverflow.com/a/2686185
+
EXTRAS
To install additional plugins, you'll need to use Sentry's local copy of pip:
@@ -45,15 +76,20 @@ To install additional plugins, you'll need to use Sentry's local copy of pip:
REMOVAL
-As of Sentry 7.1.4, this package will no longer remove the Sentry user by
-default. You must perform this step manually.
+This package does not remove the Sentry user by default. You will be required
+to perform this set manually.
THANKS
-I appreciate the tips and suggestions I've received since converting this
-package to a (mostly) pure virtualenv installation. Please report any issues
-related to the PKGBUILD on the AUR page or open a ticket on my Github
-project page:
+I appreciate all of the comments and help I've received from users like you on
+the AUR. Over the years of maintaining this package, I've had a tremendous
+amount of help and encouragement that's produced a highly usable build.
+Together, we've resolved many confounding issues, and several of you have
+isolated bugs in the upstream package.
+
+I would like to thank each and every one of you for your help and
+participation. Please report any issues related to this PKGBUILD on the AUR or
+open a ticket on my GitHub project page:
https://aur.archlinux.org/packages/sentry/
https://github.com/zancarius/archlinux-pkgbuilds
@@ -75,14 +111,14 @@ cat << EOF
UPGRADE STEPS
-1) Stop Sentry and its related services (and reload systemd)
+1) Stop Sentry and its related services (and reload systemd):
sudo systemctl stop sentry
sudo systemctl daemon-reload
-2) If you're upgrading from a Sentry version < 8.0, you'll need to update the
-configuration by hand. Sentry's configuration setup has changed dramatically
-and increasingly more options are being moved to Sentry's YAML-based configs:
+2) BACK-UP YOUR DATABASE!
+
+3) Update Sentry's configuration files:
sudo -u sentry mkdir /etc/sentry/temp
sudo -u sentry /opt/sentry/bin/sentry init /etc/sentry/temp
@@ -101,13 +137,13 @@ and increasingly more options are being moved to Sentry's YAML-based configs:
See here:
https://docs.getsentry.com/on-premise/server/config/
-3) Run the database migrations:
+4) Run the database migrations:
!!! ALWAYS BACK-UP YOUR DATABASE PRIOR TO UPGRADING SENTRY !!!
sudo -u sentry /opt/sentry/bin/sentry --config=/etc/sentry upgrade
-4) Start Sentry:
+5) Start Sentry:
sudo systemctl start sentry
@@ -127,51 +163,72 @@ To install additional plugins, you'll need to use Sentry's local copy of pip:
sudo -u sentry /opt/sentry/bin/pip install <package>
-IMPORTANT 8.0 UPGRADE NOTICE
+REDIS
-If you're upgrading from an earlier version of Sentry, the Sentry team has
-deprecated MySQL support. You will need to plan for one of the following
-options: 1) Manage schema migration manually, 2) consider migrating your data
-away from MySQL (there may be some tools to assist, linked below), or 3)
-reinstall from scratch with PostgreSQL.
+In order to facilitate installing Sentry on a containerized system (e.g.
+systemd-nspawn), we have removed Redis from the "depends" array in the
+PKGBUILD. Redis is still REQUIRED and sentry-celery will not run without it;
+however, for users where the installation of extra services and daemons may be
+an issue, we've been experimenting with trimming down hard dependencies. If
+you find sentry-celery fails to run, you will need to configure a Redis
+instance either locally or remotely.
-SENTRY WON'T START?
+OPTIONAL DEPENDENCIES
-Recent versions of Sentry included a configuration for specifying large integers
-for certain ID columns, most notably sentry_project.id. If your migrations fail
-and SENTRY_USE_BIG_INTS is enabled, try disabling it and restart the migration.
-While this is unlikely to bite you unless you've migrated from a much earlier
-version of Sentry (version 6 or early 7), it is one of the most likely blockers
-that may prevent you from updating.
+We've removed LLVM from the "depends" array as part of our dependency cleanup
+to make life a little easier for those who have been requesting reduced
+dependency builds for quite some time. Now, you should no longer need to
+modify the PKGBUILD prior to build or installation. Please note that projects
+making use of dsym (symsynd) still require the presence of LLVM. It has been
+moved to "optdepends" for this reason.
+
+I'VE UPGRADED AND SENTRY WON'T START!
+
+Verify that you have some of the installation requirements available either on
+the system Sentry is installed or remotely. In particular:
+
+ - Check that you have Redis installed somewhere and Sentry is configured to
+ use it (sentry-celery requires this for background task handling, among
+ others).
+
+ - Make sure you've run the appropriate migrations. Sentry isn't likely to
+ start without this.
+
+ - Check database permissions. Out of the box, Sentry expects the database
+ connection to run as the "postgres" user. This isn't desirable on non-
+ containerized installs; if you've changed database permissions at some
+ point, you may need to see which user Sentry is connecting as and
+ temporarily change it to "postgres."
+
+UPGRADE FAILS WITH DATABASE ERRORS
+
+Sentry expects database migrations to be performed by the super user
+"postgres" and may occasionally install plugins or other features that require
+super user access. There are two choices: 1) Temporarily set the configured
+database user to super user or 2) run the migrations as "postgres". When doing
+the latter, you may wish to change table and sequence permissions to a more
+sane state for greater security. If you need assistance doing so, please
+consult the Stack Overflow answer:
+
+ https://stackoverflow.com/a/2686185
THANKS
-I appreciate the tips and suggestions I've received since converting this
-package to a (mostly) pure virtualenv installation. Please report any issues
-related to the PKGBUILD on the AUR page or open a ticket on my Github
-project page:
+I appreciate all of the comments and help I've received from users like you on
+the AUR. Over the years of maintaining this package, I've had a tremendous
+amount of help and encouragement that's produced a highly usable build.
+Together, we've resolved many confounding issues, and several of you have
+isolated bugs in the upstream package.
+
+I would like to thank each and every one of you for your help and
+participation. Please report any issues related to this PKGBUILD on the AUR or
+open a ticket on my GitHub project page:
https://aur.archlinux.org/packages/sentry/
https://github.com/zancarius/archlinux-pkgbuilds
-SENTRY 8.9.0 UPGRADE NOTICE
-
-dsym support has been integrated into Sentry directly and is no longer a
-plugin. If you've been relying on the sentry-dsym package, you may notice that
-this package is no longer built. Instead, symsynd is installed automatically
-as part of Sentry's "install_requires" dependencies. You will encounter an
-error during Sentry's install as a consequence of this; that's normal. Remove
-your sentry-dsym package first.
-
-If you haven't previously required dsym support, this means that Sentry now
-requires that you also install LLVM for symsynd. It may be possible to remove
-LLVM from the package dependencies, but the build may fail if it's not
-installed. As a workaround if you cannot have LLVM installed for whatever
-reason, try removing "llvm" from the "depends" array, build Sentry on a machine
-that has LLVM installed, and then copy the package to your target server. This
-will cause problems if you use something that requires dsym support, but it's
-presently the easiest way to install Sentry on a target host without LLVM
-installed.
+DON'T FORGET TO CREATE A BACKUP OF YOUR SENTRY DATABASE BEFORE RUNNING
+MIGRATIONS!
EOF